@Zebra - MK4 NFO needs some changes!

vbimport

#1

First of all: I succesfully upgraded my 411s with MK4, thanks to Z.

But I was a painful process, because of wrong or missing steps in the procedure.

I did everything as it was written in the nfo that came with the patch I got at speedlabs. After rebooting I tried my first burn with DvdDecrypter an it failed after leadin(Ritek G04-R). So I decided to reboot again and try a simulation with Nero before writing ather coasters.
But right after windows logon the damn blu screen appeared with unrecoverable error relating cdr4_2k.sys.
It took me a couple of hours to get in the position of reflashing my drive, this time using ltnflash and a bin of HS0K, checking the Update BootCode option. After that everything works as it should.
The guide instead of suggesting to flash the firmware with the exe tool from liteon should suggest the ltnflash procedure and update bootcode.

I noticed another strange behaviour of the patcher: if I patch the same original eeprom several times I get every time a different patched version, is this normal?


#2

AFAIK the built-in lite-on flasher that comes with the .exe also updates the bootcode…
I also did the mod, exactly to the instructions in the .nfo file, and everything went fine.

Strange :confused:


#3

Same here. The error report suggests the OS may have misconfigured the drive after the flash. My XP install lists no cdr_42k.sys, but a search of the MS Knowledge base turns up this gem:

http://support.microsoft.com/default.aspx?scid=kb;en-us;821844

It refers to a different drive, but says the problem apparently lies in a third-party file included in MediaPlayer9.

At any rate, glad you got it sorted. Now you can settle down and start complaining about Kprobe scans like the rest of us.

:stuck_out_tongue:


#4

I don’t know if the liteon flasher updates the bootcode, the point is that using the flsher it didn’t work, using ltnflash worked great!! Maybe it was only a problem with my configuration (win 2k).

I don’t have any reason to complain about kprobe scans, you can see one of G04 here

Did anyone noticed the strange behaviour of the patcher, returnig different files from the same source?

Also the patcher doesn’t have any form of error detection: for fun I patched a bin file which was longer than 1024 bites and the patcher didn’t complain, it just truncated the file at 1024!


#5

Yes, I did.

Patcher returns different modded BIN file each time. (same source of course)


#6

Don’t stress about the patcher producing different results each time. Zebra has already stated that it is perfectly normal.

As for not using the official LiteOn firmware updater. I’ve read many, many people saying that they didn’t have a problem using the .exe updater. Actually it’s the first time I hear someone suggesting to scrap its usage. I suppose it’s more a problem with your sys config than anything else.