Yellow Exclamation Mark on USB device

I have a Liteon 411 in an external enclosure with a power switch and connected via USB. It’s been working great for about 3 months. Now, after it’s turned on a second time since a restart the system does not recognize it. Device Manager shows a yellow exclamation mark and in the troubleshooting box it says

“Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38)”

If I do a restart the system will recognize the USB device initially but if I switch it off and back on, it does not. Bothersome and wondered if anyone had an idea what has happened or how I may fix. thanks

i was advised to do the following and it worked. keep in mind anything you do is at your own discretion and risk, though. but it should be fine.

whet to do is just, right-click on the device in the device manager, and select remove device. really remove it from your system. then reboot, and windows should “refind” it and install proper and working drivers, status, etc.

i did this for my secondary ide port! but it worked like a charm. setings, drivers get corrupt, overwritten, etc.

I use Win XP pro so if you use a different OS your mileage may vary. also, to really scare you, the end of my story was, i then got i/o conflicts in the primary ide, and brazenly tried the same move on it! of course, i lost the ability to boot, completely! even in safe mode! i removed my hdd port, basically. but, winxp has a very powerful feature called repair install, and by booting from the cd, it will reinstall all os files, while respecting and maintaining the original install settings, etc. so end of the story was i got my os back just as i left it (had to go update online of course cuz all the updtated files had been overwritten, no biggie), and got my burner fully funtioning, as well as the whole pc. so happy ending.

i consider myself intermediate-level pc/os skills. if you don’t feel competent eough, you might not want to try it. but it really isn’t that painful, and frankly it might be your only solution. good luck.

You could also try unplugging the USB cable then plugging it back in (rather then using the power switch).

Thanks Snappmack! I tried what you suggested and everything is operating normal again. Actually, it was easier than I imagined it would be after I read your notes.

What I found out after my initial post is that it didn’t make any difference what plug & play device I used, it was not going to be recognized by the OS upon plugging it in a second time ( or turning it off and back on a second time as with the external 411).
The yellow exclamation point would always be attached to the appropriate device until I did a restart.

Here’s what made it so easy. I took the simpliest USB device I had, a Lexar USB smartmedia storage device and plugged it in and out until I got the exclamation point, did the right click remove, restarted the PC, obtained the “new hardware detected” and it soon was working. So to test it I unplugged it, plugged it back in and it was detected by the OS.

WAALLA!! success, so I tried other things like digital camera and the 411 burner and they all work normal. I don’t understand why removing one and re-installing made them all work but I don’t have to know why. I’m just happly at not having to do all those restarts all the time. Thanks again.
PS If it happens again I will keep your idea in mind too Ssseth, thanks.