Yamaha CRW-F1ZE Flash Failed

I originally had firmware 1.0F on my drive, but after having coasters with India-made Verbatim CD-Rs, I decided to flash to 1.0G. The burns worked for some time, but a few days later, Nero, Alcohol 120%, Windows Explorer failed to detect any media in the drive (including pressed originals.)

All burning software were able to detect the drive just fine – just not any media.

I attempted to flash back to version 1.0F (finally found the firmware for download somewhere) – it updated fine, but the problems remained.

So, out of frustration and desperation, I tried the GUI-based version of MKTFlash. It reported that it couldn’t detect the chipset (or something in that regard.)

So, I rebooted the PC and ever since then, the drive now is disabled in System Properties, indicating that the drive is not functioning any more.

I’m on the verge of trashing this 1-year-old $140 drive…

Anybody have any suggestions I can try?

The drive is currently connected as Secondary Slave.

Thanks!

Michael