Xvid vista DVDFAb incompatibiliy

vbimport

#1

I’d previously concluded that it was not possible to play generic - xvid output from fab in vista media center.

I thought this was bacause vista woudl not support xvid, but I now find that vista does happily play video converted from you tube which has a very similar xvid codec.

2 examples follow - the data had been grabbed with avitag editor.

example 1 is from youtube via easy video converter. it plays fine in vista media center video library.

example 2 is ripped from dvd with dvdfab platinum- it does NOT work in vista media centre.

can anyone explain this ???

example 1 works in vista

Codec: XviD MPEG-4 codec ‘xvid’ <0x64697678>
Kilobits per second: 258.473
Frames per second: 29.9700
Frame size: 320x240 pixels
Aspect ratio: 1.33
Frame proportion: 3x4
Effective bits per pixel: 0.112
Effective bits per frame 3x4: 8646
Video compression: 99.532%
Power of video compression: 213.7:1

example 2 - dvdfab generic rip does not work in vista media centre ( reports missing codec)

Codec: XviD MPEG-4 codec ‘XVID’ <0x44495658>
Kilobits per second: 1200.344
Frames per second: 25.0000
Frame size: 1024x576 pixels
Aspect ratio: 1.78
Frame proportion: 9x16
Effective bits per pixel: 0.081
Effective bits per frame 3x4: 64179
Video compression: 99.661%
Power of video compression: 294.8:1

it could be the audio codecs ( example 2 uses AC3), but I doubt it, & life’s too shor t to test all possible permutations.

I’d like the dvdfab authors to test their generic option outputs with vista media centre video library & either make them compatible or tell us what tweaks are needed - please

& please note - it’s specific to VISTA - the generic xvid file outputs from DVDFAB work OK in Windows XP media center edition, but not in Vista home premium media center ( with the same codecs installed as on the XP machine! )


#2

Do you have AC3Filter installed?


#3

[QUOTE=jeradc;2038024]Do you have AC3Filter installed?[/QUOTE]

yes.

the Vista PC will play the dvdfab generic xvid rips OK, in a variety of media players ( zoom, VLC,PowerDVD, when in normal windows mode

they even play ok in windows media player, thoughit pauses to say acquring codec…codec acquired… first.

the issues is that the dvdfab generic xvid rips just won’t play inside of the VISTA media centre interface i.e. they won’t play via Video library + remote control interface.

and the point of the thread was to indicate that xvid output from other sources e,g ripped from youtube does work in VMC - so what specifically is non-compliant with how dvdfab creates its generic files ?


#4

cybmole ;I posted what is in the quote below in another topic .Try to apply it to the example 2 - dvdfab generic rip .Then see if it will play form a virtual drive.The .iso should contain the same information the example 2 - dvdfab generic rip now has .
I think the problem is Vista doesn’t like to play DVD files ripped to the hard drive strait from the hard drive.

[QUOTE=cholla;2035298]Here’s what you can do to play on HD files with Windows Media Center with Vista.
First you neeed a virtual DVD drive like VirtualCloneDrive (freeware).
Once you’ve got that you need to build an .iso with the VIDEO_TS folder with a program like ImgBurn.Then mount that .iso in the virtual drive.IF you are not going to burn a backup with the VIDEO_TS you can delete it because you can always use the new .iso to create another one if you need it.
Then right click on VirtualCloneDrive in MyComputer or Explorer whichever you prefer to call it.Select Open Auto play(not Play).then from the Autoplay window select Play DVD movie using Windows Media center.The movie menu should start .Select the option you want from the menu.[/QUOTE]


#5

my issue has nothing to do with .iso & virtual drives, it’s about getting the xvid video format to work in VMC. I have DVDs working in VMC already & jsut want to solve this XVid issue.

anyway there’s a far simpler way to play DVD files in VMC than what you posted - just a 1 line reg hack & then all your DVD video_ts folders will display in place of play DVD option. I posted a link to it here a while ago.


#6

much to my suprise, I have established that the problem lies with the audio passthru ac3 component, not with the xvid video component.

I ripped the same chapter from the same dvd in 2 ways : firstly as generic default (=xvid+Ac3), then again with generic xvid+mp3. the test chapter (chapter 2) from an xfiles episode, as its nice & short & DVDfab says there is only a single AC3-2 audio stream on the DVD.

I put both output files into vista media centre & the 2nd format works OK!
the AC3 format sill works in WMP outside of VMC after it goes through its acquiring codec step, but not inside of VMC.
So I have been wrongly blaming the problem on xvid.

I then reinstallted acfilter v1.46 & retested but got the same results, so either I’ve configured it wrongly or I need to go google AC3 + vista for more clues. all I want is simple 2 channel stereo!
But this is progress, as I now have a useable dvdfab generic output mode for those clips that I want to put into VMC as video files, rather than as entire DVDs.


#7

cybmole ;My suggestion was for a work around to see if the the xvid +Ac3 would play at all in Vista’s Windows Media Center.If it did work from the .iso in a virtual dvd player with WMC Vista then the problem would not be with the Ac3 if it didn’t work it would be.
I don’t have any xvid + Ac3 to try it myself.Guess I will have to see if I can create a file like this
I"m going to look for the reg hack.


#8

[QUOTE=cholla;2038521]cybmole ;My suggestion was for a work around to see if the the xvid +Ac3 would play at all in Vista’s Windows Media Center.If it did work from the .iso in a virtual dvd player with WMC Vista then the problem would not be with the Ac3 if it didn’t work it would be.
I don’t have any xvid + Ac3 to try it myself.Guess I will have to see if I can create a file like this
I"m going to look for the reg hack.[/QUOTE]

Ok I see where you’re coming from now.
i think this is the vista registry change -

change the value from play to gallery, after making sure you’ve given yourselv sufficient privilege to save registry changes. then tell VMC to monitor the folder where you store DVDs. don’t bother organising them into subfolders because it will display the entire collection all at once.
no matter how you structure your subfolders.

Registry key - HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Media Center\Settings\DvdSettings
Registry value - ShowGallery
Registry value data type - REG_SZ
Registry value data - Gallery = enable My DVDs; Play = do not enable My DVDs

if you then want to add cover art, see my related threads or just google dvd cover grabber.


#9

cybmole;Thanks for the registry tweak it worked great .A major fix for Vista WMC.
I created a xvid + AC3 file & had the same results as you.
I did take a YouTube .flv & convert it to a .mp4 with Super.Then I used VSO DivxtoDVD I put the .mp4 in as the source file & converted to a DVD VIDEO_TS with the standard .ifo ,.bup & .vob.I put this in the DVD folder I created for WMC to play from the hard drive.It plays this video even though it has AC3 audio.Below are the GSpots of the files.The .vob is the main .vob.





#10

thanks - I think we’ve established that the “missing” AC3 codec is a vista media center bug & not a fault in DVDfab.

I’ll just change my generic default to xvid+mp3 for now. Hopefully using that with a high bit rate & volume at 100% will closely match the AC3 audio passthru, for 2 channel sound.


#11

update - could be the culprit is powerdvd7 ultra - I found this info on another board & it describes my symptoms exactly! - so I may switch to windvd on the vista PC & see what effect that has:

[quote] "PowerDVD uses their own software codec to decode DVD, Blu-Ray, and HD-DVD materials. It also decodes and plays DivX and XviD files with it’s own built-in codecs. But that also where there are issues. I found that after installing PowerDVD 7 Ultra, VMC could not play any of my DivX or XviD files. Trying to play using WMP11 (Windows Media Player 11) will produce a “Acquiring Codec” message on the lower left hand corner. However, it would quickly acquire it since WMP11 didn’t really need to download it (it’s already installed), and the movie would automatically play. Also, on the playlist, the video being played would have a red X as if there was an error, but the movie plays just fine with video and audio.

It’s a strange behavior, and no matter what codec I uninstall and try, the behavior is the same. I’ve tried the official XviD codec and ffdshow, and it’s the same thing"[end quote]

whatever, I don’t think DVDfab is at fault at all here.


#12

update 2- removing powerdvd 7 ultra made no difference - but windvd 9 ,which has built in upscaling, is a better DVD player which also works well with the microsoft remote, so it was worthwhile anyway.
check out windvd 9 alltoHD upscaling if you like to play dvds on your PC.


#13

I don’t have PowerDVD but some programs don’t do a clean uninstall.Either they leave behind some of their own .dll files or take their .dll & don’t replace the original .dll.It can be other files but is usually a .dll .
I had a software Avi2Dvd the cause WMP 11 on Vista to not play certain .AVI files.Fortunatly it uninstalled correctly.
You might try the Vista error checking to see if it will replace or repair the original .dll.