XVID TMPGEnc Xpress - no sound

Some one pleeeeeze I am loosing the will to live. I have been hunting round now for a solution to my problem

I have an AVI (several in fact) DIVX XVID with AC3 Audio (according to GSpot) All play fine in Windows media played and PowerDVD so can only assume I have the relevant codecs. (GSpot also confirms codecs are available)

I am using TMPGenc Xpress but when I create the MPG there is no audio. I have tried creating audio only and this also has no sound. After trawling thru several ‘help’ forums I have downloaded Virtualdub/virtualdubmod and Nandub with a view to separating out the audio.

When I try to load the avi in all of these I get the message
[!] Couldn’t locate decompressor for format ‘XVID’ (unknown).
VirtualDub requires a Video for Windows (VFW) compatible codec to
decompress video. DirectShow codecs, such as those used by Windows Media
Player, are not suitable. Only ‘Direct stream copy’ is available for this
video.

Any guesses guys?

EDIT : Just a thought, these are not pirate copies are they? :eek:

Please look here: http://club.cdfreaks.com/showthread.php?t=79324&highlight=sound+Tmpgenc

You may change a movie file xvid, ac3 by using v-dub, if v-dub has the ac3 decompresser loaded into it. This is done by running a freeware program AC3ACM.zip (rar) from http://fcchandler.home.comcast.net/AC3ACM/ or from http://virtualdub.everwicked.com/index.php?act=ST&f=3&t=8066&

I had the same problem, no sound so i did v-dub conversion; video to direct stream copy, audio to full processing-compression set to pcm mode. This gave me a movie file that was xvid, uncompressed. (This is a larger file) I then used AVS Video Converter 3.1 to convert it to DivX5.05 video, mp3 audio and to compliant vcd. You may send me an e-mail at doo524@hotmail.com for more info if you wish.