Xvid AVI DVD Playback Audio Sync Problems

vbimport

#1

Dear all,

Any help greatly appreciated for a self-confessed noob - a long time viewer first time poster to the forums.

I’m trying to get an Xvid AVI onto DVD and have succeeded quite well so far, only thing is I’m having problems with DVD playback audio sync.

Note: The original 700MB file doesn’t have any audio sync problems whatsoever on playback through my laptop on WMP - this is all about audio sync, I have no problems with video sync at all. I’ve got the latest Xvid codec, Divx and K-Lite packs.

Im burning with a Matshita somethingorother and a Duo Core 2 with 2GB RAM.

I’m burning the finished ISO with Nero 8 through the Burning Rom at 2x with data verification at the end on a DVD-R (Tescos 8x - I think personally theyre good quality)

I’ll try and explain this as fully as follows:

  1. I run the Xvid through VirtualDub 1.7.8 as follows:

Video > Direct Stream Copy
Audio > Full Processing Mode (like it tells me)
Audio > Compession > No Compression (PCM)

^^ Not too sure if this is right, should I be using Mpeg-3 Compression 48kbps?

Interleaving > Enable Interleaving

  • Preload 500ms
  • Interleave audio every 1 frame
  • Delay by 0ms (I think this is right)

^^ Not entirely sure if this is right - should I set it to 0 for all values or turn it off altogether?

Also not too sure with video if I should Direct Stream Copy or just Normal Recompress.

Anyway after that I get the output file which is usually around 1.6-1.8GB, also plays fine on WMP playback, no loss of sync whatsoever.

Next, I go to DVDForger 0.6.2a and load the newly tinkered about with AVI and set:

PAL
Single Layer DVD
Create ISO image
16:9 Aspect Ratio
192kbps Audio Bitrate
Audio track of video file
Progressive

I think thats about right. So I click the button, let it make the ISO. Next open it up in Nero and burn at 2x, verify afterwards. Pop it in my laptop DVD player, skip forward a little to a talky bit and there you go, its as badly dubbed as a kung-fu movie.

Any help really is greatly appreciated - what am I doing wrong? Theres a few things I can think of…

  1. In DVDForger I should set the audio bitrate to Default rather than 192kbps (dont know if this makes any difference)

  2. In VirtualDub I should use some form of Audio Compression (even though WMP playback is totally fine)

  3. In VirtualDub I should turn off Interleaving or change the values

  4. In VirtualDub I should change Video and Audio to either:

Direct Stream Copy
Full Processing Mode

Direct Stream Copy
Fast Recompress
Normal Recompress
Full Processing <-- can’t do this as I don’t have 60gb spare on my HDD.

Any suggestions much appreciated - I’m totally tearing my hair out over this.

Thanks to all, I have faith its something really simple and you all will know what to do :slight_smile:

Lozza.

NOTE: The audio is about 2-3 seconds ahead of the video.


#2

Hi Lozza_c and WC…
If I was doing it ,I’d use FAVC or DVDFlick, much easier IMO!..
But try these methods, I’ve tried, thanks to a member of another forum…
Use AVIDemux instead. Just tick the Shift box under the audio tab, and change the value. Press the stop (not pause/play) button and then play again to see the effect. All this happens in the one program, on the one page. And if you build a VBR timemap, you can adjust VBR MP3 sync as well - something virtualdubmod isn’t too happy with.
Or this,

Quote:
Open the video in MPC, then click on Play -> Audio -> Option. Tick the box next to Audio time shift(ms), and enter a number. Click OK, and play the video. Keep changing this number until the audio lines up. Once you are happy that you have found the delay in milliseconds, open the video in virtualdubmod and click on Streams -> Stream List. Right-click and select Interleaving. In the bottom section of the dialogue, marked Audio Skew Correction, enter the number you found in MPC. Click OK, OK. Click on File -> Save As, and using Direct Stream Copy, save a new, hopefully corrected, avi file.
Good luck!


#3

Edit:
I just noticed you have no sync prob with original avi …so I’d say it’s in the conversion…Most likely VBR audio…
Try FAVC or DVDFlick as recommended…
Good luck once again!..:slight_smile:


#4

If your original 700mb avi plays without issues, I don’t see why you are running it through Vdub anyway. What are you trying to accomplish by doing this? What specifications does the file have? Open it with Gspot and tell us what you are starting with.

Most of the time you can import an avi straight into FAVC and produce a good quality dvd. Then burn to disk with ImgBurn (which comes with FAVC).
Both FAVC and ImgBurn are free to download and use: http://favcfavc.googlepages.com/

Edit: This started as a separate reply, but works as a backup to t0nee1’s good advice.


#5

Thanks, I don’t know why I was making it unecessarily complicated! So gotten rid of VirtualDub TMPG and all the other useless stuff I had. Burnt the ISO of the AVI the DVDFlick made and it works like a dream.

Only one other question though - how do I convert a .divx file? As DVDFlick doesn’t support it, or well it doesn’t say so in the drop down list. Would I have to run it through TMPGEnc to encode it as an AVI first?

Many thanks.


#6

DvdFlick does support DivX…



#7

Have I got the right version? This is all I have.

The output AVI I have works fine through my laptop, but won’t play on my PS2 :frowning: Any suggestions? It was working the other day when I used DVDForger and Nero to burn. Used Nero to burn the ISO of the AVI.


#8

Maybe I’m missing something but, your OP states audio sync issues with avi/Xvid to DVD, now your posting about "the avi output works fine through my laptop."
which is it? And now PS2 issues as well…I don’t use DVDForger or Ner0 for that matter,so can’t help you there,sorry!..
But let’s try to figure out one prob at a time OK!..


#9

Okay, my apologies.

At first, I was unecessarily running the original file (AVI) through AudioDub then converting with DVDForger to ISO then burning with Nero 8.

Then, after I found out I didn’t need to pass it through VirtualDub, simply converted the original file in DVDFlick to ISO then burnt with Nero, played back on my laptop and there were no sync issues whatsoever. So basically, as I deduce it, I should’nt have been running the file through AudioDub. Since I’ve stopped doing that, and used DVDFlick for the whole process (apart from burning) its been perfectly fine, no issues whatsoever.

So thats all fine I’ve got that sorted, playback through my laptop of the AVI (I still have yet to fully run the other issue, the Divx file, through DVDFlick) is fine. However I now have issues trying to get my PS2 to read the DVD, and as this is the only unit I have hooked up to my TV, its a little bit frustrating.


#10

Right ok as a quick update, just tried it again and the ever-temperamental PS2 has decided to play the DVD fine, no sync problems whatsoever, no skipping, it is absolutely perfect. Very strange it wasn’t working earlier!


#11

[QUOTE=lozza_c;2072181]Right ok as a quick update, just tried it again and t[B]he ever-temperamental PS2 [/B]has decided to play the DVD fine, no sync problems whatsoever, no skipping, it is absolutely perfect. Very strange it wasn’t working earlier![/QUOTE]
Get a real DVD player.


#12

@ Op,
No need to apologize , glad you got it sorted out…:cool:


#13

Thanks, thanks for your help all the same.

I feel like such a fool, I tried for about 5 days to work it all out myself and I’ve learned a lot about video editing in the process, just wish I’d asked on the forums in the first place though, would’ve saved a lot of time and effort!


#14

[QUOTE=lozza_c;2072445]Thanks, thanks for your help all the same.

I feel like such a fool, I tried for about 5 days to work it all out myself and I’ve learned a lot about video editing in the process, just wish I’d asked on the forums in the first place though, would’ve saved a lot of time and effort![/QUOTE]
Or searched these forums. Almost every question has been asked and answered many, many times.