XP stopped refreshing the CD/DVD contents after changing?

vbimport

#1

My XP Pro has stopped refreshing the contents of any CD/DVD I insert after the very first disc I use in each of my DVD drives. The first CD/DVD I insert is fine, I can see the files but when I eject it and insert another disc I still get the contents of the first CD/DVD I inserted?

I can’t refresh the contents in Explorer, any program that can access the CD/DVD drive shows the contents of the first CD/DVD and I can’t install any software that’s on 2 CD’s or more as the disc swap is not recognised.

How the f*ck do I reset the volume tracking so windows will refresh the CD/DVD contents after ejecting and inserting a new disc?


#2

How many CD/DVD devices do you have?
If you have more than one they are on the same IDE cable (master, slave),
or in different one’s?


#3

I have 2 DVD drives on Secondary IDE, DVD-ROM as Slave and DVD-WRITER as Master.


#4

I think I solved my problem!

I searched the MS Newsgroups and saw similar posts about the same problem, it’s something to do with Auto Insert Notification settings and using a small program to fix it:

http://www.bigblackglasses.com/staff/downloads/autofix.exe

When you run the autofix program it will fix any problems with your CD/DVD drives, once I had restarted windows and disabled Autoplay that got re-enabled, I could insert any CD/DVD and windows would recognise the change :slight_smile:


#5

Glad that you solved your problem!! :slight_smile:


#6
  1. Enable Auto Insert Notification for CD Drives
    Some programs will disable this default setting to play inserted CDs automatically! Roxio applications do this; for example! To re-enable this functionality >>>
    � Navigate to the following Registry key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
    � Double-click Autorun
    � Make sure the value is set to “1” under Value Data.
    � Navigate to the following registry key:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer.
    � Double-click "NoDriveTypeAutoRun"
    � Make sure the value was set to “91” under Value Data.
    � Close the registry editor
    � Restart your computer.
    You should now be able to pop in a CD, and WinXP should pop up the autoplay menu and attempt to autorun the CD.
  2. Disable AutoRun for the CD-ROM
    One of the easiest ways for a hacker with physical access to a company’s PC’s to distribute malicious code is via the CD-ROM. By creating a custom CD with a payload set to launch from the AutoRun feature in any machine, a hacker can affect any number of unlocked systems without ever leaving a fingerprint or touching a keyboard. Or he/she can simply leave a few of these lying around the office marked “MP3’s”, or “Payroll Data” and wait for an unsuspecting user to simply pick it up and insert it into their machine. You can disable this function in WinXP Professional by
    � Clicking Start > Run > and type GPEDIT.MSC
    � Go to Computer Configuration > Administrative Templates > System > Locate the entry for Turn AutoPlay off

Please let us know what finally cures your problem by posting back.
Good Luck and as you can see: we are all wishing you the best of success on this glitch! :rolleyes: