XP? lite-on firmware upgrade?

I have a memorex 1248AJ and have read the post of sucessfully flashing the drive to the Lite-on LTR-48125W using the VS08.bin file. This requires using MTKflash and booting into real DOS mode.
I am running XP and the instuctions for MTKflash say to create a DOS boot disc using a w9x/me/or dos computer. Can MTKflash be used on XP to perform the flash, and if so, how do you make the XP boot disc? I tried using the windows firmware installer from Lite-on to flash the drive, but it would not work because it recognized the drive to be a memorex and not the lite-on.

to make bootdisc, goto my computer->right click on the a:\ drive->click format->under format options, click create an MS-DOS startup disc.

Then follow instructions in the guide and voila.

Download a bootdisk from www.bootdisk.com

just use Windows XP

My Computer > 3½ Floppy --> Right Click --> Format -->Tick Create a MS-DOS Start-up disk

copy MTKflash.exe and vs08.bin

restart,boot and flash,you done

:stuck_out_tongue:

MS-DOS Start-up Disk of Windows XP WORK (of course) for me (flash from LiteON 40125W --> 48125W VS08

Thanks for the boot disc info. Now I am having problems with the DOS. I know nothing about DOS. I have rebooted the computer into dos and tried typing MTKFLSH 1 R/ B /M zws4.bin to make the back up and nothing happens…Just get “bad command or file name” error. The guide says to boot from the disk and goto the file/folder where mtkflash is loaded. Perhaps that is where I am screwing up?? Could anyone Post a detailed walk through of what to type in dos… For example is there a space between the mtkflash and the r and /? I have loaded mtkflash onto the A drive in a folder called A:\Lite-On and the firmware is A:\Lite-On\VS08. I put these on the same floppy I used for the boot disc. Any suggestions?

well i notived that in here you typed mtkflsh. Its mtkflash. I also noticed that you put a 1 in the device selection. I don’t blelieve thats the correct number for you. Heres how the numbers work:

  1. Primary Master
  2. Primary Slave
  3. Secondary Master
  4. Secondary Slave

Is your drive the only other drive besides the hard drive? If so, more than likely you will want to choose 3. Once in dos where it shows a:> type: A:\Lite-on\mtkflash.exe x r /b /m file.bin
where x is one of the numbers referenced above.
there is no slash befor the r.
Where file is the name of your memorex firmware.

After it backs it up and you’re ready to flash type:
A:\Lite-on\Mtkflash x w /b vs08.bin
You may have to type the full pasth of vs08.bin, but i think you might not. If you do, you will know because it will tell you couldn’t find input file or something similar. If this happens, type the above command except change vs08.bin to A:\lite-on\vs08.bin

That should take care of it, only problem i can think of would be running out of space on the bootdisc. When i flashed me drive, i made the bootdisc by itself, and used another one for mtkflash and the firmwares.

Good luck.

ok, booted into dos typed A:\Lite-on\mtkflash.exe 3 r /b m/ zws1.bin to back up my firmware. mtkflash acted like it was doing something (i guess, had a blinking curser on the next line) but the drive lights were doing nothing. So I waited about 10 mins and came back and still had the blinking curser and tried to type…no keys would do anything, had to control alt del to get out.I figured it might have worked, I already have a back up of my current firmware with a windows installer… So then I typed
A:\Lite-on\Mtkflash 3 w \b vs08.bin and got the same thing…mtk was obviously up…with blinking curser…waited about 15 mins and nothing happened. Will it say complete or something? Then I ctr alt del nero says I still have the same memorex drive and firmware…? What am I doing wrong here? Is it really worth all the trouble. I am burning 700mb svcd movies at 3:07 what kinda gain might I pick up from this ??

well maybe 3 isn’t the proper number to be using. If its all input correctly, it will do stuff. It will show updating bank (i think thats what it says). You’ll know if its doing something.

What other drives do you have on your system?

We need to find out which number you memorex falls under. Look inside your case and see if your drive ius set to master or slave and is it on tha same ide channel as the hd (the thing that connects to the motherboard).

I have a memorex1248aj, a compaq dvd 115, a 1.44 floppy and a 80gb maxtor hd. The ide cable first goes from the motherboard to the hardrive, then to the memorex and then to the dvd. I am sure the memorex is set to cable select, because it has a little blue pin cover and a diagram on the back. the other drives have no diagram, but if it is in the same place…the hd looks like it is set on cable select too? does that make any sense?

Originally posted by shadow.22
I have a memorex 1248AJ and have read the post of sucessfully flashing the drive to the Lite-on LTR-48125W using the VS08.bin file. This requires using MTKflash and booting into real DOS mode.
I am running XP and the instuctions for MTKflash say to create a DOS boot disc using a w9x/me/or dos computer. Can MTKflash be used on XP to perform the flash, and if so, how do you make the XP boot disc? I tried using the windows firmware installer from Lite-on to flash the drive, but it would not work because it recognized the drive to be a memorex and not the lite-on.

You’ll have to use the .bin firmwares with mtkflash & not the original lite-on ones.

im not sure if you can do it with it on cable select. I am almost positive it needs to be master or slave to work. You could set it to one or the other, flash, then set it back to cable select.

The ide cable first goes from the motherboard to the hardrive, then to the memorex and then to the dvd
.

Are you sure its not one cable for the hd and anothe for the dvd and the burner? I don’t think you can have three ide devices on the same channel.