XP Booting takes too much time

vbimport

#1

I recently got me an AMD64 CPU. Together with that I bought me a MSI K8T NEO FIS2R mainboard.

I got the system up and running but I have this strange issue: booting XP takes a lot of time (about 2 minutes). I am booting from my RAID controller (I use the Promise controller of the board) from a RAID-0 array (WD Raptor disks). When the loading screen of XP shows (the black screen), it doesn’t seem to be doing anything for about one minute. After that, the HDs start loading and it all comes quite quick.

I can’t figure out why the system idles for about a minute. There’s no DHCP client running on any of the network interfaces (IEEE1394 / Lan), all my hardware is installed, properly configged and running on the latest drivers etc etc. FYI: without any driver for any hardware part of my system installed (except for the RAID drivers of course), the delay is precise the same.

My XP is fully updated. I don’t want to run MS Bootvis, as that once completely f#cked up my system. I already did a reinstall but no luck there.

Linux doesn’t have any delay while loading, so it must be some software issue!

Any thoughts?


#2

You’re right, it has to do with drivers or software that installs drivers for that software to work. I had the same issue a while ago after installing a certain piece of soft(ice)ware (for debugging :wink: ) . Try installing your programs and drivers one at a time, do a reboot if required after each installation. It should show itself then.


#3

IT might be a hardware(ish) issue.
I found that mine was doing that and after a while it was a network card that had nothing plugged into it.
I use to network 2 machines, but after a re-jig in my room I disconnected it, but windows use to wait about 90 secs for the other machine to respond :confused:
Took the card out and put it in a new slot and problem solved.

So the moral of this story is, try taking out peices of hardware and when it boots OK then you know what drivers to look at.


#4

I assume when you say you did a reinstall that means you reformatted your hard drive and then apply a new coat of XP?


#5

@Slayerking: well I only have to install three hardware drivers: mainboard (includes network, firewire, usb, sound, lan, ide etc), my ISDN card (isn’t the problem, I already checked that) and my graphics card… no problem there :slight_smile:

@Petera: only think I can take out is my ISDN card, but that isn’t the problem (I put it in later anyways, the issue was already there)

@Vanderlow: deleted partitions, reinstalled both XP and Linux…


#6

Do you have anything attached to either usb or firewire? If so then unplug them and see if that helps. It could be waiting for a device to respond.


#7

This may be a lot of work but have you tried O/S other than XP to see if they take an unusual amount of time to boot and load?


#8

Seeing as you have taken the time to reinstall etc. I would give BootVis a shot. The ‘Trace’ function should provide the info you need. It is the ‘optimize’ function that has caused problems for some. But it does sometimes erroneously report that disk caching isn’t enabled.

Maybe a quick check of your HD’s performance would provide some info. This free utility is worth a peek.

http://www.hdtune.com/