XP Autoplay

vbimport

#1

Whenever I insert a disc into my litey or my samsung dvd-rom, the XP “What would you like to do with this disc” menu pops up. I pick Take No Action, and check the box for it to never show up again. It doesn’t matter though, these messages pop up any time I insert any disc. They never stop. Is there some way to edit the registry or something to nuke these windows?


#2

Have you got CloneCD installed? If so go to Settings and disable ‘Enable Auto Insert Notification’. That always does the trick for me (although I am sure there are other ways to disable the auto insert notification, this method is just very easy when you have CloneCD installed).


#3

I have the same problem with my XP and Media Player…

With Plextools, In the general information section, you click on options, then click the general tab here and uncheck the “Autoplay Audio CD’s” box and that keeps my Media Player (by default) from popping up for that session.

However, even with the “Save settings on exit” checked, sometimes when I come back into Plextools, for another session, the Media Player pops up again, then I go to the option window again and somehow my “Save settings” box is UNCHECKED…Weird…

Even in all the options tabs on the Media Player windows, there aren’t any places I’ve found to stop this action…

Someone told me Microsoft does this on purpose…


#4

Edit the registry :
look for:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom
on “AutoRun”:
“1” for enable
“0” for disable
:cool:


#5

Autorun is not the same with autoplay.
The best is to use the microsoft powertoys (tweakui) and configure autoplay as you want.


#6

Install CloneCD

Tools => Settings => Auto Insert Notification => Unncheck it.
Tools => Settings => Auto Play => Uncheck both

You can play with the settings you need.

:cool:


#7

go into my computer and right click on your cd-rom/writer and select properties then click on the autoplay tab, in the dropdown list select the different types of cd’s(eg music) click “perform action” then in the window click take no action. If you have the option “prompt when cd is inserted”, it will ask you everytime, now only cd’s that have autorun files on them will autorun.:wink:


#8

TWEAKUI from POWERTOYS FOR WINDOWS XP is IMO the easiest way of tweaking all these sorts of things and a lot more - definitely worth the download and install - wouldn’t be without it! :cool:


#9

Go “Start”>“Run” type “gpedit.msc”(without quotes) then expand User Configuration>Administrative Templates and click on the System folder. In the right pane select “Turn off Autoplay”
Note: This setting does not turn off the Autoplay for music cds.


#10

For those of you who would prefer the registry entry to turn off autorun for CDs…

From Microsoft Knowledge Base Article - 330135…

[B]A value of 0xb5 in the following registry key turns
off the AutoRun feature for CDs:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDriveTypeAutoRun

You must set the hexadecimal value to 91 to enable the AutoRun feature.[/B]

Go to Start–>Run and type regedit.
Find the above key, and set the value to “b5” (hexidecimal).
It will show as 0x000000b5 (181) after you hit OK.

I just popped in a blank CD-R and no autorun. :bigsmile: