XJ-HD166S - New firmware

vbimport

#1

New firmaware DS18 - 2003/05/05

Match more media :confused:

URL http://www.jlms.com.tw/download.htm

:bigsmile:


#2

Yeah, yeah… http://club.cdfreaks.com/showthread.php?threadid=69208

:smiley:


#3

Originally posted by NetLion

Match more media :confused:

:bigsmile:

And… It now works with Roxio’s Easy CD Cremator, sorry, Creator. Version DS14 didn’t :wink:


#4

I don´t know why a lot of people remains using Cremator.

There are a lot of good burning progs ages better than this problematic and erratic soft.

:confused:


#5

Hi,

what is the difference between the LTD-166s and the XJ-HD 166s?

I bought a JLMS LTD166s recently, Nero Info Tool says “Firmware DIS2” (what kind of Firmware is Dis2??), and everytime I try to update the firmware to DS18, the Flash Program says No matched drive detected! This Utility is only for JLMS XJ-HD166s
Drive.

What’s going wrong there?

Thank you,

Jackie


#6

DIS2 is an OEM firmware for the 166s. Probably for Fujitsu-Siemens computer.
Go to my Flashfix page (click) get XFlashfix (a special DS18 Flashfix!) and fix DS18 with it - takes a second

Now you’re ready to flash your drive and make it a genuine JLMS XJ-HD166s DS18 :wink:


#7

Hi Mango,

many thanks for your help, you are great, the patch worked fine!

Can you tell me ehy Liteon is doing this? I was buying this drive in a german computer online store as new, and I would have bought retail but I couldn’t find it anywhere, so I selected bulk.

And of course, I have nothing to do with fujitsu-siemens or so, I always build my computers by myself, so this is simply annoying that OEM drives cannot be upgraded the regular way. But it’s good to know there are people out there like you who can help :wink:

cu,

Jackie


#8

You’re welcome Jackie but the thanks are really going to Dale, he wrote the utilities.

I’ve given up on trying to understand Liteon’s politics but I know there’s not much profit in manufacturing those units. When Fujitsu or other big OEM buy from them in big bulks they probably get a better deal if they take over the firmware upgrade and support (which they don’t bother much with).

Strickly speaking these drives are not meant for retailing, but that’s an old story…

Enjoy :wink:


#9

I used the XFlash utilty, and started the patched firmware utility. After i hit the flash button, he reaches 100%. But after that, he said: flashing did not succeed, please contact vendor. When i check with Nero infotool, the firmware version is DS18. Can i expect the firmware has been upfgraded. or is it only the versionnumber that has changed?


#10

The flash must have been successful. It starts by erasing the old one and if something had gone wrong you would have a ‘dead’ drive now.


#11

No, it just plays fine my audio-cd’s so i guess nothing’s wrong


#12

I have a JLMS XJ-HD166S Drive it looks like it came with DQS7 firmware (which I can’t find listed anywhere). This is an HP drive that is rebadged. I tried to flash to the latest version on the JLMS site DS1E and got the error:

No matched drive detected!
This utility is only for JLMS XJ-HD166S Drive.

Detected drives:
1-0-0-0 E:JLMS XJ-HD166S DQS7

I tried using Flashfix utility but that didn’t work either. I drug the DS1E.exe file to the flashfix window and it gave an error:

Couldn’t find known string in dropped file.
Is file a Windows Flash Utility? Compressed?

Can you provide any help?
Thanks very much!


#13

get this: http://codeguys.rpc1.org/firmwares/166S.DS1E.patched-rs.rar


#14

So anyone try it and is it any good? :confused:


#15

You must have forgotten UPX. It must be present at the same dir with Flashfix, becuase ds1e.exe is compressed.