Xbox Linux Help



I had a few questions about making a linux-xbox the softmod way.
So far, here are my materials:
-Original copy of Mechassault
-a usb 4 port hub
-an extension cable
-a creative labs muvo tx 256mb flash drive
-sid4 files using mechassault

My Kernal version is 3944 and my dash version is 5960.

In the case of the Mechassault, it is not platinum, and it has the correct part number it should to do the linux thing. In the case of the port hub, i have connected it to the extension cable in this manner: the extension has a red, white, yellow, blue, and green wire. The hub had a red, white, green and black wire. I connected them red to red, white to white, blue to black, and green to green. The extension has copper wires and the hub has silver, so i dont know if that would effect anything or not. In the case of the flash drive, according to a list i read, it is compatible for this modification. I downloaded all of the mechinstallers and extracted them with WinRAR. I havent really used ozxmemory yet.

This is the order I have tried things in:
First, i put mechinstaller 128 mb on the flash. Next i went and inserted the hub/extension into the 2nd player controller port. In the first port i had my controller. Next, I turned on the xbox after i inserted the flash drive into one of the four hubs. It turned it on and the xbox logo stayed up a little longer than usual. Finally it came to the main menu. I checked the memory to see if it had recognized my flash. No change. I then waited a while to see if it took some time. Still nothing.

Finally I went to my friends a burrowed a pen drive from him. It did show signs of working when i connected it to the usb adatptor for the xbox because the small light in the back of it lit up. I then took the pen drive out of the adaptor and put in my computer where I moved some sort of files called ā€œsid4ā€ onto it. After moving the files I put it back into the usb adaptor in the box and started it up. I went to the Memory section on the main menu and still no sign of a memory card. My pen drive is in FAT32 format, and the sid4 files are in XBX format. Could it be how the pen drive is formatted or maybe what format the files are in?