Writer reads but wont write

I am currently building a new PC. Built 100’s before with no problems.

I believe the problem maybe due to the IDE Controller not recognising the DVDRW as a UDMA Device.

When the properties are selected, the normal tabs appear, ie.

General/Driver/Details/Rescources.

there is no way i can get it to read with primary channel and secondary channels.

System Info.

Gigabyte - GA-K8VM800M m/b
A64 2800+
1 Gig Crucial Ram
160Gb ata133 on IDE Slot 1
NEC 4550 on Slot 2

I have tried all different conbination, master, slave, vice versa etc, to no avail.

I am used to using Motherboards with an IDE Channel. PATA Channel, and SATA Channels.

This motherboard has only SATA and IDE(PATA)
Motherboard says
2 ide connections(udma33/ata66/ata100/ata133 for the connection of 4 drives.

I have a ata133 on the primary master
dvdrw on the secondary

the drive is recognised in windows, actually the windows has been installed from this drive.
Nero 66015 and other packages recognise the drive no problems.
The writer isnt faulty, tried it in another PC.

Can anyone point me in the right direction?

Some things to check/try

Use Microsofts default IDE drivers.
Try an 80 conductor IDE cable
Make sure UDMA mode is enabled both in your systems BIOS and in Windows device manager.
Uninstall any packet writing software such as Nero InCD.

and DLA!
Also flash your BIOS with the current FW!

Sounds like a settings in the BIOS regarding DMA / IDE.

Thanks very much guys for your replies. Finally found the problem.
gigabyte supply VIA 4in 1 Drivers v4.55 on their site. These don’t work.

I installed an older version v4.53 from another source, and all worked ok.

Funny that. Cheers anyway…