Write error media error

Hi people hope someone can help.
I am having problems backing up my dvd,s on my emprex 16x 10016im.
I keep getting error messages halfway thro the copy usually says write error/medium error 003.
I have a p4 512mb dell. my cdr copies no problems. using verbatim dvd-r taiyo yuden tyg02 media.
usually use roxio 7 or 8 but have tried nero 6 too and still wont copy.
My drive recognizes the disc and will plat them but not copy them.
Any help greatly appreciated.

Welcome to cdfreaks. :slight_smile:

A firmware upgrade might help, but emprex doesn’t seem to care that much about their customers…

BTW, this is a rebadged BTC drive, know to be a bad burner.
Maybe you’ll find some useful firmwares here.

Hi thanks. Have already tried new firmware now running on a092 but it didnt make any difference. just doesnt seem to burn althought there is power there and is does playback a dvd.
Is there anyway i can test the drive before i bin it? it,s only just over a year old. wasnt that good anyway from the start.
If shot can anyone recommend a good dvd burner (not too expensive).

much aprreciative for your help.