"write caching and Safe Removal" greyed out, please help

vbimport

#1

I’m having a problem with trying to disable write caching. I have 4 hard drives, and am using XP Home SP3. I’d like to disable write caching, but in the device manager, under the drives’ properties, the options “Optimize for quick removal” and “Optimize for performance” are both grayed out, with “Optimize for performance” ticked. Underneath that, “enable write caching on the disk” is unchecked (that is not grayed out).

This is the same for all 4 drives. I’d like to select “Optimize for Safe Removal”, but it won’t let me. Can anybody help?


#2

I think you can only do that with memory sticks?


#3

Ok, now I understand. I just popped in a usb stick, and for that device, the options are available. I also switched on my usb hard drive, and for that drive, the options are also available. That makes sense. Thanks for the quick response!


#4

Externals are limited in the options you can make on to them especially due to the limits introduced by the connection type. :frowning:


#5

Came here through a Google search late, but I have a question, though.

If I plug in a USB stick, go directly to the device manager, and check the Properties|Policies on it, it will have “Optimize for Quick Removal” selected.

However, if I open up an Explorer window, right click on the drive and choose Properties|Hardware, select the drive, Properties|Policies, the Write caching and Safe Removal section is grayed out, but it has “Optimized for Performance” selected.

Is there a reason for the difference? Is the Device Manage the final word on the drive’s policies?

Just wondering. Thanks.

Robert


#6

There is always a reason. :wink:

Normally you can choose the mode via the device manager settings.