Worst dvd-writer ever...BTC 1008

vbimport

#1

Hy all,

Just bought that damn dvd-writer 5 days ago, and since then i have an continuously headache 'cause of this…It’s impossible to set it in DMA mode (it writes and reads an dvd in ONE hour), plus it can hardly read the dvd’s burned 10 minutes ago. :frowning: DO NOT BUY THIS CRAP.

Cya,
Rollo
www.advisor.ro


#2

Hi rollo vx:

Could you describle your computer system ?


#3

lol the problem is not the drive, but your computer setup… and whoever set it up… ive been using this burner since it came out and have never had a problem… through all the firmware updates (which ive updated each time they came out with one and always runnign the latest)

ive been using cheap to brand name discs… dvd-r/dvd+r/dvd+rw/cd-rw/cdrs… etc u name it… burned, played, and played on other set top drives just fine…

sucks that u have a problem with yours but if u give it to me im sure it will work just fine…

first tell us what kind of system u have…


#4

Hi,

I have : MSI KT Turbo (KT133 chipset). I tried to install different versions for VIA IDE drivers, tried the “uninstall Secondary IDE channel” trick…etc. I know it’s not my comp fault cause i’ve tested the dvd on different comp and it has the same problems. Plus, my older Sony cd-writer works just fine in DMA mode. I’ll wait till monday and have it sent back to replace it with something else…anything else but btc.

Cya,
R.


#5

And if the next drive is one of the few percent that are faulty? Never again that brand? Based on what you’ve told us, we should avoid buying your particular drive, on the chance that it may really be defective and not just improperly set up. My BTC 1008 has burned dozens of discs without difficulties.

Strangely, many of the most serious complaints about the drive are posted by people for whom the first step after failing to get the drive set up properly is to curse it and/or smash it against the wall. Both of these methods have been tested to be largely ineffective. Trouble shooting using the search function, returning the drive to be checked out, and contacting technical support, on the other hand, have been shown to solve almost any problem.

JD


#6

I clicked this thread because the thread title was so sensational. :frowning:

DMA not working makes a product worst?!


#7

You can’t burn a good quality disk while not in DMA mode.

Since the drive cannot get data from the computer fast enough, it is doing either of 2 things:

  1. It is burning the disk at the speed you want but constantly engaging buffer underrun protection. This constant stop/start of the burning process never produces good results.

  2. It has fallen back to 1 speed burning, but the statagy of the drive at 1 speed on the media you are using is a producing bad results. This can be either because the drive is simply incapable of burning your media at such a slow speed, or because BTC has mostly focused their attention to the full speed statagies.

Either way, get DMA running, burn some disks, then complain about how bad BTC are.


#8

I have the BTC 1008 and have read over 50 DVD’s and burned over 80 on this unit with firmware 0054. NEVER had a single coaster and every DVD plays without problems. I had it set to PIO mode 4 initially and changed it to DMA without any trouble. Perhaps you have a defective unit.


#9

I’ve had this drive a while and suddenly had bad burns with it on checking I found it was running in PIO mode and couldn’t get it into DMA mode. I’ve always updayed the firmware but decided to flash it back to a previous version, flashed it back to 0658 it is now running in DMA mode again and my discs are burning successfully, it seems to me that it’s something to do with the firmware, as it only started to go wrong when I flashed to 0059


#10

ANYONE HAVING PROBLEMS WITH DMA…

Try this… it usually works for me…
posted it a while back…
http://club.cdfreaks.com/showthread.php?t=106198


#11

Finally replaced the drive with a new one (it’s not identical with the old one because the led it’s round, not square and it has the writings engraved on plastic, not painted). Anyway, this one works perfectly so far, in DMA mode. It seems it was something wrong with the old one, a physical problem not a software one. Too bad i lost 4 days trying to make it work… And yes, “DMA not working makes a product worst”.

Cya,
Rollo


#12

Gotta say I was impressed that I had it working perfectly on a 450Mhz P3 machine. (Even watched DVDs with Videolan!) :slight_smile:


#13

I thought the BTC1004IM was the worst! :iagree:


#14

I have the BTC1008 - and would not say it is the worst drive at all! It is not great, but not terrible.

It sounds like the DMA could have been a drive problem, pleased you got the new one working. WHat brand is it?

Cheers
WDA