Work around for memory allocation problem

vbimport

#1

First of all I like to stress that the memory allocation problem of DVD2one V1.2.2 is not a bug in DVD2one. Obviously the memory management functions of Windows XP and 98 are not working properly. We did not find any problem with V1.2.2 on Windows 2000.
Anyway, I made a work around for the problem, and although I am quite sure it will work, I rather test it properly before releasing it. If you have the memory allcation problem, and want to help testing, please mail me using the form on the DVD2one website.

Erwin


#2

Emailed you!


#3

Just tried the 4 movies that were giving me a memory allocation error. The new Dvd2One works great on my system(s). I used DvdDecrypter 3.1.6 and Dvd2One 123 with full disk backup. Both variable and constant mode work great. Also tried AnyDvd 1.4.1.1 and did not get any encrypted disk error that I was getting on certain movies.

Used 2 separate computers with different types of harddrives, motherboards, video cards etc. Both systems had WinXP Home (NTFS).

Movies tested: Shanghai Knights
Catch Me If You Can
Happy Accidents
The Guru

Speed increased. SIMPLY PERFECT!!! QUICK RESPONSE TO THE PROBLEM!!!
ONE VERY HAPPY CUSTOMER!!!
Thank You Dvd2One Team!!!:bow: :bow: :bow:


#4

System Spec Amd 1800 cpu, 1gb ram, Maxtor 80gb system drive, 120gb WD1200 8mb cache as 2nd drive. Disc Ripped using DVD Decrypter 3.1.6.0, to 120gb drive and processed to 80gb drive. Use XP Home with SP1 and all updates, on NTFS partition.

Disc Used UK Version of 24, six disc set. 4 episodes on each. Tested Disc One, Full disc copy. Variable ratio. Ripped size 7,446,851,584 bytes.

First run full disc rip through DVD Shrink to compress only the menues and extras.
Finished as 7,398,479,872 bytes . Tested all episodes, navigation, sound and extras before putting through DVD2One. No problems.

Run DVD2One on original ripped file, pre scanned very quickly, seems faster than previous version. Target capacity used was 4479mb, my standard. Processing speed seems same. Total time 21 min 25secs, about normal for my system, on this size of file. Finished size was very slightly larger than normal at 4,701,634,560 bytes.

Tested all episodes, navigation, sound and extras no problems.

I then ran the SHRINK processed file, Total time was 20min, 15secs , file size 4,700,082,176, Tested all episodes, navigation, sound and extras no problems.

Picture Quality seems very good, cant see any improvement on my 19” monitor over previous versions. No sign of the memory allocation error, and no problem with SHRINK files.

Looks like you have cracked it. Hope this helps.


#5

Worked for me as well. I also tried it with Swordfish and anyDVD, 51 minutes direct from DVD. Erwin looks as if your work around has solved the problem.


#6

Hi m8,

an Email is on its way. Nice one!


#7

One would imagine that the amdfix.sys in completely redundant on an intel-based system (and hopefully not needed by AMD-chipset/cpu users…).
But if it werks, it werks…thanks.
Now, about this ForcedSub thingy…:smiley:


#8

I have the memory allocation on win 2000 and XP, then I get the message to copy full disc all files must be there or something like that, how do I email for the solution


#9

I have enough testers at the moment, so please do not mail me anymore. Thanks to everybody willing to help!

Erwin