WoooKao patch corrupted Windows & device driver for CD rom

vbimport

#1

I loaded the Wookao patch to work with the DVD Fab’s latest version software. Although it did run the Blue Ray in the Blue ray player under the DVD Fab program - DVD Fab no longer works to load a DVD. In fact you cannot load a DVD, CD or any other recordable media now in DVD Fab or just in Windows 7 since the device no longer has communication - and checking the device manager - It displays a error code now - stating " Windows cannot load the device driver for the hardware. The driver may be corrupted or missing (Code 39). I am running Windows 7 - 64 bit. It is a windows driver- 6.1.7601.17514, location in C\ windows\system32\ drivers\ cdrom.sys.
Everything worked prior to loading the patch. There is no information on the software and what it does. Even if you plug in an eternal Bluy Ray\ DVD\ CD device - the system will not recognize it.
The is nothing on the computer to uninstall - to undo the patch.
Before I go searching for a driver replacement - What is your suggestions for a Solution/ Fix? - I don’t want to do something that makes the problem worse if that is not the solution (Reloading a driver).
What does the software change - where is the problem where it is saying the driver is corrupted.
Being that is windows program driver - what is the correction(s)?


#2

Thread moved to DVD Fab forum.:wink:


#3

I am checking on this.


#4

Have tried using imgburn to see what your filter driver load order is? As you may have a filter installed that should not be. That usually causes the problem you having


#5

AGJ is correct, and neither DVDFab (nor woookao AFAIK) install any registry filters. This exact symptom has been reported and discussed on one of the Microsoft forums, please take a look at this: http://social.msdn.microsoft.com/Forums/windowsdesktop/en-US/cbbfde77-4def-4abb-8dd0-125c6eb9441d/done-windows-cannot-load-the-device-driver-for-this-hardware-the-driver-may-be-corrupted-or?forum=windowscompatibility and this http://support.microsoft.com/kb/314060


#6

The installer is exe is fine but I sure wish they had put an uninstaller with the free decrypter like most of them do.


#7

Thanks for the link. I had already found this link, however I was waiting to see if someone responded about the software patch itself - and what it targets for change. I have access to 3 computers Running Win 7- 64 bit. Each has either a external Blue Ray Burner, Internal Blue Ray (the one that has the driver issue now), and a laptop that Blue Ray player/ DVD burner. When I look up the Device driver in each - the common file is the: cdrom.sys . The one that is attached to the External - has a couple files that appear to be related to storage and have the .sys extension. What I was looking for was the possibility of a missing file/ or updated version of the cdrom driver. All 3 computers range in age - but they all appear to running the same driver # and date. If it was a missing file - I would have attempted to place one of my other computers driver files in a Temp folder, copied the original somewhere, and see if it would update and correct the device. It is just odd that the device stopped working after the patch .exe file was executed - wanted to make sure the patch did not displace a .dll file that ran in conjunction to the cdrom.sys file somewhere else.
The Blue Ray Burner is a LG BH16NS40 - and I was searching for an updated driver for it - because one of Microsoft’s suggested solutions is to load an updated driver. LG’s site does not have a driver per say - it has a firmware update. That is not the same as an updated driver is it?? Potentially I can load that… But I want to try the suggested Microsoft fixes first…
Does any one know of a location you can get a updated driver newer that 2006 (year version in anything I have) for Win 7 for the dvd rom?


#8

Woookao targets DVDFab. It does not make any changes to the registry filters around the optical drives, or mess with the device drivers for ODDs. This is based on my experience with it and information from what would be considered a highly reliable source.


#9

The cdrom.sys on my Vista OS says it’s 2009 but since there is no version numberI can’t say it’s actually a different one.
The one in my XP Pro is from 2002.
On my laptop W7 home it says 11/20/2010 It has aversion 6.1.7601.17514
On the laptops XP Home it says 4/13/2008 version 5.1.2600.5512
Where you would get any of these except from MS or another OS you have I don’t know.
This shows there are newer versions.

IMO this driver is not the problem & I have seldom seen deleting the filters that are always recommended work.

Try a chkdsk & if that doesn’t repair the problem do a SFC /Scannow.


#10

[QUOTE=John8449;2733772] What is your suggestions for a Solution/ Fix? ?[/QUOTE]

Disable automatic startup from every cd-dvd related software,then disable your security programs for a specified time interval,then
remove the drive from device manager,reboot and let windows install the driver again.

And if you have a windows recovery disc instead of a recovery partition,you can try cholla’s fix too…


#11

[QUOTE=roadworker;2734188]And if you have a windows recovery disc instead of a recovery partition,you can try cholla’s fix too…[/QUOTE]
The chkdsk is the same as error check it just takes a right click on the OS hard drive /Tools/Error Checking then schedule for next boot.

Although not the ideal way SFC /Scannow can be ran from inside Windows & even better in safe mode. As roadworker posted the best is to run from the recovery console command window.

roadworker’s other suggestions are also recommended ones.

If you follow the procedure in this link & you don’t need to copy sdelete into it for this to work. It will boot you into a recovery command window from a flash drive.


#12

[QUOTE=cholla;2734189]SFC /Scannow can be ran from inside Windows & even better in safe mode.[/QUOTE]

I always thought that the sfc /scannow command needed a windows cd to put the files with the correct timestamp back…:o


#13

[QUOTE=roadworker;2734195]I always thought that the sfc /scannow command needed a windows cd to put the files with the correct timestamp back…:o[/QUOTE]

I’ll look into that but I think the only problem it would have is with a file that is constantly in use by Windows.
It also sometimes fails to make some repairs . So far from a “perfect” solution.
I suspect it gets it’s information from the files in the winsxs folder . Those should have the correct timestamp.

This is a good article on it:
http://support.microsoft.com/?kbid=222193


#14

[QUOTE=cholla;2734196]
This is a good article on it:
http://support.microsoft.com/?kbid=222193[/QUOTE]

Cheers for the link!:smiley: