Won't recognize blank media - tried EVERYTHING?

Hi,
I have a problem which is all over the internet, however, nothing has helped me yet.

This started after formatting my hard drives and reinstalling Windows Vista.

Any disc, CD as well as DVD can be read perfectly fine, except the blank ones. The drive just won’t recognize them and asks me to “insert a disc”.
On occasion (has happened two times) auto play will pop up as it normally would but burning will fail in the finalising process.
I have spent three days googling on this problem and here is a list of what I have tried to save yours and my time:

  • Upgrading to latest firmware
  • Degrading to older firmware
  • Uninstalling the drive in Device manager and let Vista reinstall it
  • Uninstalling the IDE blabla in Device manager and let Vista reinstall it
  • Make sure the cables are correctly inserted
  • Downloaded every current driver available from hp.com for my computer, including BIOS update
  • Installing third party burning software (Imgburn)
  • Uninstalling third party burning software (again, the computer is clean with no Nero, Roxio etc)
  • Trying to burn from Windows Media Player
  • Lower/upper filters in regedit (same as the quickfix from MS)
  • Setting the value to 2 in regedit to make it a writer (it wasn’t set to 2, but still no luck)

…and certainly some methods that I have forgotten to mention.

Please, before asking me to buy a different brand or new drive, have in mind that this has worked perfectly fine until my reinstallation of Vista. I had this problem some months ago, then caused by Nero, but again - no third party burning software was installed when this first occured this time.

The media I tried is Verbatim DVD+R DL if that is of any help.
My computer is a HP Pavilion a6127.sc with a HL-DT-ST DVDRRW GSA-H30L drive.

Half my Kingdom to he or she who steps forward and solves this problem.

A blank media CANNOT be read. only recognized by a burning app & burner.

I guess my lingual shortcomings didn’t make everything clear, but normally when one inserts a blank disc the autoplay pops up wondering what you want to do with this media - burn, burn an image etcetera.
My problem is it says no disc inserted - both in the windows and explorer or any burning application. It also ejects the tray as if, again, there was no disc in it
This is a very common problem.

http://www.google.se/search?hl=sv&client=firefox-a&rls=org.mozilla%3Asv-SE%3Aofficial&hs=izb&q=burner+recognize+blank&btnG=Sök&meta=

You can always try the drive in another pc.

Is virtual drive software installed, daemon tools, alcohol, incd…?

[QUOTE=chef;2280266]Is virtual drive software installed, daemon tools, alcohol, incd…?[/QUOTE]

Good question - even if you’ve had these programs installed, but have removed them, they often leave behind drivers and other bits that can still cause the same error message.

BTW, welcome to the forum :slight_smile: