Woe are my efforts to backup my copy-protected game play disk

vbimport

#1

Hi,

I’m at my wits end here. I recently purchased Far Cry (the 5 CD version), and have patched it up to v1.33. My mobo and video drivers are all running current drivers as well, and my DVD-RW drive (Benq DW1655) is running the current firmware.

My problem is this: I’m trying to create a backup of the Play Disk (D1), and I can’t get the final disk to work. Here are the steps I took:

  1. I looked at the type of security using Aray, just to be sure, and it was SafeDisk2/3.

  2. I start Alchohol, go to the Copy Wizard, modified the file dump setting appropriately (I’m trying to dump the play CD of Far Cry to an .mds file), following BCN_246s guide and other similar pointers from other helpful posters.

  3. Once the process starts I see row after row of disk read errors. I let the job complete, per other comments I’ve seen in this forum, then continue with the burn to CD, complete the disk write, and enable the emulation settings and then try to run the newly burned CD.

  4. I get the message that’s something like ‘cannot locate correct CD. please insert correct play disk’. I’ve tried ejecting the disk and reloading to see if that makes a difference, but no luck.

  5. I’ve tried on three disks using varying read/write speeds, but all the resulting burns get the same results

I’ve found that the CD doesn’t mount in My Computer, although when I look at the disk info through Alcohol, I can see that the file size is right. I can’t seem to mount the disk, but from what i’ve read it sounds like I should just be able to start the game by clicking on the shortcut on the desktop.

Can anyone help me out here? It seems like some minor step or setting that I’m missing. Thanks a lot!

  • J

#2
  • Even with ‘Bypass EFM error’ and SD emulation there is no guarantee that a burned Safedisc 3/4 copy works
  • There are few devices that can’t even create a working image (the only one i experienced myself was BenQ 822)

P.S.: What is the first defective sector when creating the image ?


#3

I’m not at that machine at present, so I don’t have the exact sector info, but I think it was something like 940, then it would continue to read the disk, and kick out another error at 952…and so on.

So it sounds like the error messages are commonplace when burning the image using the SafeDisk 2/3 setting in Alcohol…are you saying that this problem may be more related to the drive itself and not with the software?

Thanks!


#4

The main problem with Safedisc (CD) is the burning of the weak sectors (located before the defective sectors). The higher the SD version, the less drives are capable of burning a runable copy (and i guess BenQ’s never were Safedisc 3/4 killers). If your device interprets a “weak” sector of Safedisc as defective even a mounted image can’t run the game. Provided that there is only one 5CD version of Far Cry, there must not be any error before sector 919.

Can you try with a friend’s/relative’s drive ?

P.S.: - before burning better always test whether the image runs in virtual drive

  • Don’t copy ‘on the fly’ !

#5

That is extremely interesting. Didn’t think it would be related to the drive. I’ll see what I can do re: testing with another one. I know there have been many drives indicated in this forum about which are good security killers, but can you recommend any current ones on the market that are good for both game-related security issues as well as drives that are don’t encounter issues/read errors with DVD decryption?

Thanks again!


#6

Is it essential for you to have a burned copy or would you be also satisfied to start Far Cry with a mounted image (which your drive most likely can create) ?

LG 4163B

Unlike Safedisc on CD successful DVD movie decryption depends much more one software than hardware.


#7

Hey Terramex: Thanks for the responses. I don’t need a backup CD, but part of the problem, it appears, is that the read errors during the image dump create an unuseable image (mds) file. I’ll try it again to see if the image file will work. I’ll also keep in mind about the errors occuring prior to sector 919.

On the DVD side, I’m using Decrypter and Shrink. Haven’t had too many problems aside from the fact that now my home player only takes Verbatim media. I got a new rig with new hardware and for whatever reason some burned DVDs won’t play in the home player (3-4 yrs old) whereas before I could use super cheap generic media. The disks play fine on the computer and I’ve handed out testers to folks. Most of the burns all work on other players. Weird.


#8

Hey Jromi.
I backed up my copy of Far Cry Using Game Xcopy and a Liteon LTR52327s CD Burner.
The Reason you cant back up your copy is because it is made with a Digital Signature built in to the burning process. Game Xcopy can read this signature and make an Exact copy.
The best part is it runs without any emulation software. :slight_smile:

Bye
Lucky Phi11