WMP does not see .wav files in the "media files- all types" drop down

vbimport

#1

Im using WMP9 and it plays wav files fine, however when I go to Open>Files, wav files do not appear as “media files- all types”. The only way I can select them is to go to the “any files” drop down. Then I can see the wavs, select and play them fine.
WMP is my default program for opening wav files.
This is a minor problem that has been annoying me for sometime. Any help would be appreciated. Thanks


#2

Welcome aboard :wink:

Do you see the following in the drop-down list? The following screenshot is taken from Windows Media Player 11.

If this or one of the file types are missing, this likely indicates the registry info Windows media player uses for listing the file types is missing or damaged.

If you’re using Windows XP, you could try installing Windows Media Player 11.



#3

No I don’ see that whole line, just the one above it and below it.
I’ll go to WMP 11 and see if that fixes it.
Thanks for the tip!


#4

I found out that Windows XP mode in Windows 7 has Windows Media Player 9, so I’ve exported the Windows Media Player File Open type registry settings if you would like to try importing it into the registry.

To install, close out of Windows Media player, extract the attached zip file, double-click the reg file and open. Then confirm to import into the registry. Then check if the ‘wav’ file type appears in Windows Meida Player->File-Open.

Note: Don’t apply this registry file if you’ve already upgraded to 11, as this may remove some additional file types Window Media Player 11 has.

wm9_registry.zip (683 Bytes)


#5

THANKS!!! Worked perfect., it now sees wavs and still see and plays flacs. I just downloaded that this morning. I really want to thank you for your help. I’d buy you lunch if you lived nearby!!:clap:


#6

No problem, glad to hear it’s fixed. :slight_smile: