WMP 11 "connect a burner and restart the player"

Yeah I got Windows Media Player 11 installed on my computer and when I go to burn a cd, I click on the BURN tab and on the top right pane it shows a picture of a cd/dvd drive with a red arrow going across and below it, it states: “Connect the burner and restart the player”.

I have a TSST TS-H652D CD/DVRW thats from Toshiba Samsung. I checked and it is completely compatible with Windows XP HEREHERE

Although Windows Media Player does read the cd’s or dvd’s I put in the drive. It doesn’t recognize it as a burner it seems.

I already went to Properties on my drive and made sure that “enable burning on this drive” was checked.

Does anyone know what I should do. Please don’t recommend using another software program. I don’t want to ignore this problem. Thanks guys. Ask me for anymore questions if you need it.

I fixed my own problem. first I rolled back to WMP 10 and it said the same thing but in a different way and on the pop up took me to a microsoft link and there it told me to go to RUN>type in Services.msc>Double click IMAPI CD-Burning COM Service> Turn it on let it load and good as new!

I’m having a problem with installing a burner, i tried doing as the previous one posted, but it still didn’t work, i don’t know what to do. I can’t burn cds :sad:

I tried this fix on my WMP 11 and it worked great thanks… :flower:

I have been trying to fix this problem for months with no luck read your post.
It worked in 2 mins.

Thanks very much.

WOW - this worked!!! Thank you so much! :slight_smile:

im not verry good with computers but is rthere anyway you could explain where to go on and what to do any easier as i really need to fix this problem please thankyou.

I just Registerd to give thanx to Kurse for posting WMP 11 fix. This problem was been driving me up the mad but it works just fine now thanx.

Oh my God!!! IT WORKED!!!

I also just registered to give thanks! Well, THANK YOU KURSE! This was driving me nuts!!!

I have an Aspire 1603ELM laptop (good laptop) and a Matshita UJ811 drive (terrible drive - probably the worst you can have)

Thought I might chime in. If you have 2 different media players installed, (for example, WMP 11 AND iTunes), you need to get rid of one of them. I would recommend uninstalling iTunes - personal preference. As soon as it is uninstalled and your computer is restarted you should be able to use WMP just fine.

If you continue having issues there is nothing to do but contact Microsoft Support (this is very costly if anywhere in your product ID # you see OEM) The per call fee typically ranges from $59-$79 depending on the purpose of you call. (I don’t know how much they charge for help with WMP. I do, however, know that a lot of times if it is your FIRST call to Tech. Support they will not charge.

To check your product ID # go to “Computer” - it may also say “My Computer” (depends on what version of windows you are operating on). Click on Sytem Properties (may just say properties) and somewhere on that page, typically at the bottom it will show your product ID #.

Well, good luck!

I managed to fix this problem in about 2 minutes having spent weeks trying to figure it out. Here’s what worked for me. First off i got the “please connect a burner and restart the player” even though my philips DVD ram burned dvd’s and cd’s with cdbunerxp without having the recording tab on it’s properties in the “my computer” window.

I went to start>control panel (classic view)>system>hardware tab>device manager>click the dvd/cd-rom drives bit> uninstall the dvd driver>click the ide ata/atapi controllers thing>uninstal primary ide channel.

Then i went back to control panel and ran “add hardware”. It found everything it needed to find. First thing i checked was in “my computer” i right clicked the dvd drive, clicked properties and looked for a recording tab, it was there for the first time! Then ran wmp 11, and behold, under the burning tab it asks "please insert a blank cd/dvd. I was so happy! i hope it works for you guys too!

Peace out.

P.S. I registered to make this single post because I couldnt see a single solution on the net to this problem, I hope mine is it.

Hello,
I have tried “all of the above” remedies for WMP and to no avail…none have worked! I did find out that every time I start my computer the IMAPI CD Burning Service is always in the “stop” mode. Could this possibly be why I can’t get WMP to recognize the burner? I’ve been on/off this problem for months now. I even reverted back to WMP10 to solve the problem, no luck, this problem will not seem to go away!!
HELP! :sad:

Hey Sportie,
I found some info on another help forum (no i’m not registered with them) that led me to find my own solution. My problem was that IMAPI was also set to “stop” mode. Just wondering, did you know that you yourself can set it to “start”?

I did this…

  1. Go to Control Panel and open Administrative Tools.

  2. Open Component Services and then select Services.

  3. Find IMAPI CD-Burning COM Service. I left-click and bring up properties and ‘start it from there’, but as you will see there are other ways to ‘start’ it again. I just like to go into properties to learn more about my computers systems.

It should be good to go! Just for good measure I also made sure the “Start-up Type” was set to ‘Automatic’. Again you can do that in properties on the General Tab.

Really hope this helps… :slight_smile:

Hi,
Thanks so much for the reply! Well, I’ve tried that option earlier in my quest to get WMP to burn, didn’t help. Really don’t know what to do anymore! I contacted Microsoft via email, they were no help at all.
It’s odd that this “connect burner…” didn’t appear until I updated WMP to version 11. I have even gone back to the older version (10) and still same problem.
There has to be something that I’m not checking…I’m just not sure what it is. :doh: YIKES!

Hi! Another frustrated newbie to the forum. I have the same problem under both wmp10 and 11, and have tried restarting the imapi, re-installing drivers, rolling back, and two different burners, a pioneer and a new sony dru-830a. The funny bit is that it works the first time after restarting, recognizes the burner, burns the cd, everybody’s happy. If I close WMP11 and re-open it, it fails to recognize the burner as a burn device. Reads fine, plays fine, no burn option. Burning is enabled under my computer, control panel cd/dvd devices, etc. I played with cmos settings last night and I have two hard disks on ide 0 as SATA, and the Sony and a mistumi player on ide 1, also as sata. Everything works with Nero, and Creative Mediasource organizer(though it fails to see the burner after WMP11 fails to see it). I personally am happy just using nero, but my daughter finds it tough to find her stuff with. Any other suggestions? I’ve heard of this being related to DRMs, but I don’t know what to do about that.

Please help I am about to jump out of the window. I have media player 11 w/ window vista. A couple of months ago my library was completely erased, I have never been able to get the songs back to the library, however, I found a way around it. Now my I’m getting connect a burner and restart. I tried all of the instructions posted to no avail. Please help!!!


After much searching, this worked for me.

I need some help I have searched for a solution to my issue with windows media not detecting my burner I have tried almost every thing I’ve found. I am using Windows media player 11 with Xp pro sp 2. heres the message "connect a burner and restart the player"
Any suggestions.

I had the same problem and tried everything, I have just solved the problem and it works perfect the message has dissapeared and I can burn again.

Its very easy and took 2 mins.

start - control panel - system

click hardware tab,

open device manager,

expand cd/dvd drives.

Right click on your recorder drive and click uninstall.

( you drive will be uninstalled and will no longer be on the list )

click on action on the top tool bar

click on scan for hardware changes

your drive will be re-installed.

now open win media and click on burn.

SORTED !!

Thanks, But that was the first thing i tried. with various combination of uninstalling reinstalling progs and rolling back to prev versions starting and stopping imapi service setting up virtual drives as burner and still no luck. installing obscure windows updates and and fixes, and editing my registry.