Wireless Network connection problems after fresh XP install on Dell PC

vbimport

#1

Hey guys and gals,

I have tried researching this problem but had no luck.

Basically, I am having problems getting my wireless internet to work on a Dell PC after a fresh install of Windows XP. Before the install, everything worked perfect, there were no connection errors or connection problems.

However, after the new install, the computer does not connect to the internet through the Belkin USB adapter. It lags for a bit on “Acquiring Network Address” then disconnects, and it keeps repeating this process. Eventually, after about 10 or 20 minutes of acquiring and disconnecting, a successful connection is sometimes made.

I believe that this is NOT a hardware issue. The router works 100% fine since the main computer (non-Dell) which is connected through the router works fine. I also have 2 Sony wireless laptops lying around the home and they connect to internet just fine through the router. There is also NO problem with the Belkin USB adapter / dongle, since i tried installing it on one of the laptops and it connected to the internet through USB adapter no problem.

The problem, i believe is a OS software issue on the Dell PC - perhaps some settings which need to changed or configured. I would greatly any suggestions as this problem is just driving me nuts and makes me deeply regret ever installing a fresh copy of XP.


#2

Check that the Belkin is finding [B]your[/B] network and not some weak signal coming from a neighbor’s network
If it’s “wandering around” and eventually locking onto a neighbor’s network, you will have to set up a new profile with your network’s info.
If it’s finding your network, then it’s possible that refreshing the driver might help.

You may still have the instructions that came with the Belkin unit, if not…

  1. Unplug the Belkin USB device
    2.Thoroughly clean out the old Belkin driver.
    3.Reinstall the new Belkin driver
    4.Shutdown and then plug in the USB device
    5.Restart…Windows should find the new device and install it

You will probably have to go through settings again…station ID, security settings, etc.
IOW, create a new profile for the Belkin to use for each session.


#3

Thank you very much for your reply jflan.

I am 100% sure that i am connecting to own Belkin network. No other networks are detected except my own. I also tried many times to reinstall the driver both from the CD-ROM and the Belkin website, but with no luck.


#4

This might not make a difference, but are you using zeroconf (the built in wireless software of xp) or are you using the software that came with the usb device to connect to the internet? I have a Belkin usb wireless adapter and I find if I use the Belkin software I get a better connection, don’t know why. Anyway, just a thought.


#5

Thanks for the suggestion Whappo.

However, i have already tried using both, but it didn’t help the connection.

It’s really frustrating to have this problem arise since everything worked fine before the fresh install. I can’t figure out what might need changing in order to get it working again… All other computers in the network connect flawlessly, but not the Dell for some reason.


#6

O.K. You can do a little “process” of elimination experiment. Make sure you have the Belkin software controlling the wireless connection. Then go to Stat/Run and enter services.msc, you will see a window pop-up with all the services of xp. Scroll down until you come to Zero Wireless Configuration, right click on it and select Properties. there should be an option to stop the process, select that and the zeroconf process will be stopped. This way you will at least know that it isn’t a conflict between the Belkin software and zeroconf. You can always restart the process again or it will automatically restart when windows restarts.


#7

Have a look here:
http://www.ncsu.edu/resnet/windows/ipconfig/
Esp. section 4

It may be useful to compare returned data to that of one your “healthy” machines.


#8

Sorry for the late reply, i’ve been unusually busy this week!

Anyways, thank you very much jflan for the tutorial link - it really helped. I did some further research and set up a static ip address and also disabled the Zero Wireless Configuration - and this resolved the problem i was having.

A BIG THANKS also to Whappo for your suggestions and helpful input. I really appreciate the both of you for taking the time to help and i’m sure others have as well. Thanks again.


#9

Glad you got it sorted !