WinXP - Linux

I have magnaged to break my booting system.

I have windows XP installed, on the primary partition on the hard drive on the primary master hd on one IDE channel.

On the primary partition on the hard drive in the slave possition on the same channel, I installed redhat 8.0, with the GRUB boot loader, while the primary master was unplugged. Once redhat was installed, I pluged the other HD back in, and booted into linux a couple of times.

The reason for doing this was to try and keep the everything compleatly separate, and not have to bother with the linux boot loader when booting into xp, and to choose, by switching the boot device in the bios from one hd to another.

The problem is that when i switch the boot order back to boot from the windows XP HD, it comes up with an error;

NTLDR not found, press Ctrl+Alt+Del to restart the system.

I presume this means that the windows NT loader is missing.

:a

I have tried repairing the MBR, and boot record, using the winXP recovery options. - no good. I surspect that this maybe something to do with the fact that i now might have two partitions that are set as active boot partitions or something to that effect. Althoguh that does not explain where the NT loader has gone.

Any solutions that will get things working by just switchig the bios boot options, and prefrably dont involve re-installing XP would be appreciated.

(also on a side note does anyone know;

  1. How can I mount an NTFS partition so i can read it in linux.
  2. And secondly how can i get my network card not to auto negotiate link speed, and manually set it to 10Mbps and full duplex mode? (also in linux)) :slight_smile:

Well, if can’t boot in windows, you have to repair the installation. In that way you will not lose any data. Boot from windows cd and select repair this intallation. (not the Auto Repair that askes for a floppy).

[If remember right, i had my mandrake 8.2 linux that way in the second hd and windows xp worked fine :confused: ]

Could be the crub? i used lilo.

Have you tried remove the slave disk with linux?

You could remove the second hd and repair winxp.

By the way, the Mandrake 9.0 version configures and mounts ntfs partitions itself, with rights both to root and the default user. if you are new at linux you could check mandrake.

@nb-

i recently installed mandrake 9.0 as well you have to configure lilo or grub to boot to either os. it does not matter that you have 2 boot partitions that is what it is supposed to be. the ntldr has been overridden by lilo/grub.

what you need to do is go into the configuration panel in mandrake and find boot then select the drive xp is installed on (eg hda1) and add it to the boot screen.

hope this helps

http://www.google.be/search?hl=nl&ie=UTF-8&oe=UTF-8&q=mount+ntfs+linux&meta=

http://linux-ntfs.sourceforge.net/info/
http://linux-ntfs.sourceforge.net/info/redhat.html

have ntfs support compiled somewhere in your kernel

mount /dev/hda1 /mnt/windows -t ntfs


the times i had that msg about nt loader i unplugged my hd, and plugged it in again, could’ve been because of an ide cable not being properly inserted, but anyway it worked again then :wink:

Thnaks people, the reason winXP wasnt booting properly, was because the primanry master had been disabled in the bios, so the computer didnt spend ages looking for a primary master that was unplugged :rolleyes: (opps) whiulle i was installing redhat. For the NTFS support, thanks i found that, but havent had time to try it :frowning: yet.

But does anyone know how i can set the network card to run @10Mbps, not 100, which it always tries to auto negotiate to and fails for some reason so i end up with no network :(.

the network card thing i’ll have to search for at home, but just for info’s sake, my mandrake 9.0 read files from ntfs without any options - it must already be in the kernel.

I’ve just managed to dual boot WinXP Pro and Mandrake 9.0. (I know absolutely NOTHING about Linux but wanted to give it a go). I already had WinXP installed first on one HDD, then I run the Mandrake CDs to install it onto my 2nd HDD.
In the BIOS I have the First Boot Device set to HDD 0. Now when I power up my PC and just after the memory test I’m prompted with the Linux Mandrake boot loader. So I’m not sure whether the linux boot loader overwrite the NTLDR, but everything seems to work using the liloGUI boot loader.

Also, Mandrake 9.0 has a choice of 3 boot loaders: liloGUI, lilo, and Grub. I’ve only heard of 2: lilo and Grub. I tried Grub but didn’t like it. Maybe liloGUI is a new feature with Mandrake 9.0, and not in earlier versions? I don’t know. Like I said, I know absolutely NOTHING about Linux, but I’ve had a lot of fun trying to get it to work!

BTW, I was going to do a complete format an install Mandrake only and use it as a workstation for fun. But then my Counter-Stike skillz would suffer due to a lack of practice! LOL :stuck_out_tongue:

I am told you can get Counter-Strike to work through wine :slight_smile:

yes, you can.

Thanks guys, I’ll try some Wine!

As my post above says that I’ve installed WinXP and Mandrake 9 successfully, I did this by having 2 HDDs - WinXP installed on one HDD, and Mandrake installed on the other HDD.

So would it be possible to have the 2 OS’s on the same physical HDD, provided that it was partitioned?

eg: 1 x 20GB HDD with 2 partitions. WinXP installed on one partition, and Mandrake installed on the other partition. 2 OS’s on the same physical HDD? That way, I can use my other HDD just for storage - mp3s, movies etc.

Thanks again in advance :slight_smile:

thats exactly how mine is set up right now. install winxp first, and then install mandrake. the only trouble is that winxp can corrupt your mandrake install, because its winxp. i’m not a partitioning expert yet, but im looking into hiding the partition, to see if that solves the problem :wink:

but yes, its easy to be done, my mandrake was up and running in 20 minutes.