WinOnCD 5 w/latest SP keeps crashing

vbimport

#1

I got WinOnCD.5.0.2.826.Power Edition and I grabbed the latest Service Pack and tried to fix my problem with that. The problem started ever since I tried burning something with my new Lite-On 52x burner (listed in my rig). It crashes after like 2-3% of the burn or on the second song. It just pauses, and freezes up. Ctrl+Alt+Del won’t even kill it but will let me shut down sometimes . I looked at the preferences and the dll file with the drivers for burners, and the 52x isn’t even listed there, but the latest 48x is. However, it shows up as the appropriate 52x in the burner menu’s. WinOnCD worked flawlessly with my old Samsung burner. This problem started after a hardware change so I know I should start looking there but have no idea where to look next or what to try. I made 7 coasters already trying to fix the problem. My only thought next is to try new WinOnCD 6 but I think that all it has over 5 is DVD support. If anyone has it, please look at drivers and let me know. Anyone have any ideas what I can do? If its a driver issue I would appreciate if someone tell me and I will give my e-mail out to get the new dll file with drivers. If anywhere, I guess it might be in WinOnCD 6.


#2

If it only happens with audio discs, it might be a problem with CD-Text and DMA.
Try it with CD-Text disabled.
More info about that problem here:
http://club.cdfreaks.com/showthread.php?s=&threadid=72503


#3

Yes, so far I have only tried audio cd’s, havent tried a data yet. However, that thread points out the problem only in Nero. I also uninstalled WinOnCD as of now. It p*ssed me off. I already converted them to wav’s and I saw no option for cd text. Unless its turned on by default :confused:


#4

Originally posted by xtacydima
However, that thread points out the problem only in Nero.

Because it’s the only program he tried.
The rest will fail as well.
The problem is the busmaster drivers, not the burning program.

Only Feurio might work with CD-Text enabled thanks to its special tricks to avoid that problem.

Anyway, the problem probably lies in busmaster drivers/DMA/IDE drives fighting in the same IDE cable, etc., even if data discs also fail.

I also uninstalled WinOnCD as of now. It p*ssed me off. I already converted them to wav’s and I saw no option for cd text. Unless its turned on by default :confused:

It has to be in some place… I hope (I haven’t used WinOnCD in years).


#5

But I seperated the way my ide drives are laid out. I have only one burner. I like new WinOnCD cause of its awesome wav editing options. Any idea’s how to fix this.

Why did it work with a previous burner then?


#6

Originally posted by xtacydima
Why did it work with a previous burner then?

I’m not sure if the problem is the same.
If it works fine with CD-Text disabled, then it is.

I guess the hardware has its relevance when dealing with these bugs, but I’m no expert so I can’t say for sure that it depends on drive.
Plextor are prone to errors with busmaster drivers, for instance…


#7

What exactly is cd-text. Do I even need it? I just like to remove the 2sec gap and sometimes do fades btw tracks. Also volume adjustment and minor things. What is cd-text exactly, like what does it do?

Just reinstalled, turns out that cd-text is its own icon option, I slectd only audio.

More od an update, even simulate cd write fails.


#8

I repeat what I wrote in the other thread:

CD-Text is the way to put text (artist, titles) in an audio CD.
Most readers can’t read that info, so it isn’t widely used, but the support is growing.
http://www.feurio.de/English/faq/fa...le_cdtext.shtml

http://www.feurio.com/English/history_1_60.shtml
“Problem: IDE-CD-Writer, DMA and CD-TEXT:
Unfortunately there have been several problems with IDE-CD-Writers, if DMA mode is activated and CD Text is to be written: On some systems the system crashes when writing the Lead-in.
The reasons for this are faulty IDE Busmaster drivers. To write CD Text, an “unusual” block size (96 bytes per sector) is used. It would appear that many busmaster drivers are unable to cope with this.
We have now tried to include a few “tricks” to transfer the data to the driver in a “more digestible” fashion. Please let us know if this has improved writing CD Text. It could of course also mean that these tricks make writing CD text not work on other systems - in this case please also send us a message!
Just to clarify the situation again: This is/was not an error in Feurio! - It is an error in many IDE Busmaster drivers which were probably only tested by the manufacturer with “usual” data block sizes - and still contain errors which only occur with “unusual” block sizes.
If writing CD text with active busmaster drive operation does not work with this version either, we can only continue to advise you to deactivate busmaster operation and to urge the vendor to finally correct the driver.”


#9

Not using cd text. Just checked.


#10

Then that’s not the problem, although a DMA/IDE problem would still be likely.

The 1st I’d try would be another burning program. Also check if WinOnCD can burn data to discard problems due to a faulty drive.


#11

Nero, CloneCD, Fireburner, and Burnatonce work fine. Its just WinOnCd that doesnt work ever since I switched to a diff burner. thats why I don’t think its a software problem. Its not an option.


#12

OK.
If the rest of programs work fine, perhaps it’s what you said first: your drive isn’t still/well supported in that version.

I can’t help you with WinOnCD issues.


#13

thats what i suspect, but anyone have winoncd 6? Maybe a newer dll file with newer drivers are what will resolve my issues.


#14

OK, so WHY IN THE WORLD did I bring up a thread from 1+ yrs ago… yep cause I have NO FREAKING LIFE…thats right!!!

Ok…well now… actually I just gave it another hoot, and I figured out the problem. If anyone else has a Lite-on 52x (gee like most people he don’t right) and WinOnCD 5.x keeps crashing on them… download the latest UniDriver with info for the recorder:

http://www.roxio.com/en/support/videopack/software_updates.jhtml

It seems to have fixed the problem, and I can now burn past 3% without the machine hanging :bigsmile: