WindowsUpdate_80070424

hi, i have this problem (a Windows Vista update error), which i have been trying to fix. i have searched on google which lead me to some possible solutions which i have listed below.

Click Start, select run, type: regsvr32 wuaueng.dll

if that doesn’t do the trick:-
>>
>> Verify that BITS is correctly configured and started:
>>
>> 1. Click Start, click Run, type services.msc, and then click OK.
>> 2. Double-click Background Intelligent Transfer Service.
>> 3. In the Startup type box, click Manual, and then click Apply.
>> 4. Click the Log On tab, and then verify that the service is enabled in
>> every hardware profile that is listed. If the service is disabled in one
>> or more hardware profiles, click the hardware profile, click Enable, and
>> then click Apply.
>> 5. Click the General tab, and then click Start.
>>
>> If that’s all okay, then perhaps:-
>>
>> 1. Click Start.
>> 2. Choose Run.
>> 3. In the Run box, type (pressing okay after the command) :-
>> Regsvr32 QMGR.DLL
(this suggestion is from here):

on the last step mentioned in that post i got the following error:

The module “QMGR.DLL” was loaded but the entry-point DllRegisterServer was not found.

Make sure that “QGMR.DLL” is a valid DLL or OCX file and then try again.
the final thing i tried is making a batch file as suggested here

when i ran this batch file, after rebooting it states that i have not had any updates installed:

i am dual booting Windows XP Pro with SP3 and Windows Vista Ultimate 64 bit with SP1.