Windows XP keeps switching DVD drive from DMA to PIO

vbimport

#1

hi, i have a Lite-On 16X DVD drive which has been giving me periodical DMA timeout errors when running in UDMA2 mode. i've found quite a few entries like this in my systems log;

Type: Error
Source: atapi
Category: None
Event: 9
Description: "The device, \Device\Ide\IdePort1, did not respond within
the timeout period."
Data (Bytes):
0000: 0f 00 10 00 01 00 64 00 ......d.
0008: 00 00 00 00 09 00 04 c0 .......À
0010: 00 01 00 00 00 00 00 00 ........
0018: 35 1d 00 00 00 00 00 00 5.......
0020: 00 00 00 00 00 00 00 00 ........
0028: 00 00 00 00 00 00 00 00 ........
0030: 00 00 00 00 07 00 00 00 ........

if this happens more than 6 times, Windows XP will force the drive to PIO mode permanently. it's happened a few times already, and i wouldhave to uninstall and reinstall my DVD drive to get it back up to UDMA2 mode. however this is only a temporary solution as the DMA errors still occur. i'm trying to resolve this issue and was wondering if the Master/Slave setup might have anything to do with it. currently i have;

Primary Master - HD in UDMA5/ATA100 mode
Primary Slave - free

Secondary Master - DVD in UDMA2 mode
Secondary Slave - CD-RW in PIO4/Multi Word DMA2 mode

is my setup ok? I'm a little worried about my CD-RW not being able to support UDMA mode. could this be hindering my DVD drive's performance causing those damn DMA errors? i'm thinking of two alternatives.

  1. Have my DVD swap places with my CD-RW.

  2. DVD AS Primary Slave, and CD-RW as Secondary Master.

will any of this make a difference, or is something else causing the DMA timeout errors? i noticed the errors occur when the DVD drive is trying to read a disc and takes a little longer than it should. when this happens some stuff on Windows will slow down for a few seconds, including the modem freezing. i would really appreciate some opinions/advice from you guys. thanks!


#2

It’s a M$ OS, there is bound to be problems.

I suggest you move the DVD to primary slave and the CD-RW to secondary master.

Try if that works.


#3

This worked for me

If you have a VIA chipset on your mobo,

You can download the VIA IDE Tool, this will force your hardware into whatever DMA mode you want :slight_smile: that your drive supports

Works any IDE device,

You can download it here

http://downloads.viaarena.com/drivers/others/IDE_MPD3014.zip


#4

i just tried swapping my DVD to secondary slave and CD-RW to secondary master. i still get DMA timeout errors. i may try switching the DVD to primary slave, but i heard that would hinder the speed of my hard drive since it’s running in UDMA5 and the dvd is only UDMA2. is this true?

KING, that link for the IDE tool seems to be dead. i can’t download the file. btw, i have no problem setting my DVD drive to UDMA2 mode. it’s just the DMA timeout errors that keep occurring and Windows XP will have to force my DVD drive into PIO mode.

does anybody know what could be causing the DMA timeout errors? in my case, i notice they occur when the DVD drive is attempting to read the contents of a disc and takes a little longer than usual, the “read” light continues blinking and whatever i’m running on Windows will slow down for a few seconds. for eg, if i’m playing an audio file it’ll sound choppy, and data traffic on my modem would halt for a while. is this behaviour normal for a DVD drive? cos i know for sure i’ve never experienced this problem with my CD-RW drive.

i never knew something like this could drive (no pun intended) me so insane but it is. hope you guys can help me out!


#5

The link is working fine ???

Is DMA set to Auto or enabled in the BIOS ?

What other drives do u have in yr pc ?


#6

yeah, the link is working fine now. downloading the IDE tool right now. the server must’ve been busy earlier. :wink:

in the BIOS, i have DMA set to Auto, and i just thought of something and tried changing the settings for the DVD drive manually to UDMA33. no luck, still getting the DMA timeouts.

i mentioned my drives setup in my first post;

Primary Master - Hard Drive in UDMA5
Primary Slave - FREE

Secondary Master - DVD-ROM in UDMA2
Secondary Slave - CD-RW in PIO4/Multi-Word DMA2


#7

You other option is to make CDRW primary master, DVD primary slave and move your HD over to secondary master.


#8

Hei,

Do you have VIA IDE miniport driver installed on your system? If YES then I think that this could be a problem.

Had almost the same DMA problem with my IBM 120GXp which was always being set down from DMA 5 to DMA 4 if I had VIA IDE driver instaled. If I uninstalled this driver, problem dissappierd.

I do not know if this helps but try.

Staljin


#9

i just tried setting up my DVD drive as the only device on Secondary IDE and removed my CD-RW. DMA timeout errors still occur.

tazdevl, is it ok to have the boot hard drive as secondary master?

staljin, how do i check if i have VIA IDE miniport driver installed?


#10

I have almost the same problem with my VIA/AMD system. I have read an article whenever WinXP detect errors with your drive, it will automatically reduce the interface speed one step by one step, like from UDMA5 to UDMA4 and lower and lower… Until it find a comfortable speed.

I have done a fresh install of WinXP, my HDD is running fine at UDMA5, but both of my Asus50x and LiteOn32@48 are running at only MW DMA Mode2. No matter what I do, install VIA4in1, miniport driver, still couldn’t get both of my CDROM and CDRW drive to run at UDMA2. Any idea?

Any of you able to run your LiteOn drives at UDMA2?


#11

sure niel, my Lite-On is in UDMA2. go to your BIOS and enable UDMA for CD-ROM. that’s how i got mine to UDMA2 from Multi Word DMA2.

i need help with these DMA timeout errors i’m getting tho. like you’ve mentioned, Windows XP will force the drive to PIO mode when too many errors occur.


#12

I have enable UDMA in bios for all the controllers(Primary & Secondary), but the problem persist. I am using MSI K7T Turbo 133A. Don’t know what could be wrong.


#13

hmmm, have you tried uninstalling your Secondary IDE channel in Windows and rebooting? when Windows reinstalls the IDE channel and redetects the drive, it should revert back to UDMA. also, in my BIOS there’s a special option called “Enable UDMA for CD-ROM”. if this is disabled and i’ve enabled UDMA on the Secondary IDE channel where my DVD-ROM is, it still won’t be in UDMA. maybe you could check your BIOS if such an option exists.


#14

There is no such option in my BIOS. Thanks anyway. Perhaps my motherboard couldn’t support UDMA for CDROM/CDRW. I have flashed the M/B to the latest BIOS though.

Actually, sometimes it will revert to PIO mode. What I did was uninstalling the Secondary Controller in WinXP and reboot. Everything back to MW DMA Mode 2, but not UDMA. :frowning:


#15

MW DMA mode 2 = DMA enabled!!!

Nothing to worry about as long as it do not say PIO only…


#16

Multiword DMA and DMA are not the same thing. MW DMA mode 2 = 16.6MB/s.

Look at table 2 in the following doc:

www.dell.com/downloads/global/vectors/atascsi.pdf

This basically says that PIO4 = MW DMA 2.


#17

MW DMA Mode 2 = 16.6mbps
UDMA 2 = 33.3mbps

Does that make any different for the performance of this LiteOn writer?


#18

It sure would make a difference if we are talking of burning @40x. The data transfer speed @PIO4 is unlikely to support burning @40x. Might result in too many buffer underruns…


#19

my own experience with drives going into pio mode was the same as 4th alphabet the way i fixed was to go into bios and set up each drive individually {don`t }use the auto mode in bios use the user setting for each device press return and it will find the device as either a hard drive or dvdrom or cdrom then save new settings and restart machine i hope this helps

  cheers  spike

#20

hi spike, i’ve already tried toying with my BIOS, with every possible setting it allowed me. i can get my DVD drive to UDMA2 mode no problem. but it’s the DMA timeout errors that it produces that i can’t solve. that is what’s causing Windows XP to eventually force the drive to PIO mode. it is not something that happens right away, but it will happen. it’s just a matter of using the DVD drive constantly enough.

i’ve gotten quite a lot of feedback from people experiencing the same problem. surprisingly, noone seems to know what is causing these DMA timeout errors.