Windows XP & FireWire Drives

vbimport

#1

I am really really stumped. I have a Toshiba Satelitte P25-S526 here. Since most of you probably have no clue what system that is, it’s a laptop with the following:

Pentium 4 HT 3.2 GHz
1.0 GB DDR RAM
80 GB Hard Drive
Intel 865PE Chipset
Integrated Sound, Ethernet, WLAN
nVidia GeForce FX Go 5200

The problem is that when I connect a 4-pin FireWire (or i.Link or IEEE-1394 or whatever you want to call it) cable to any of my 3 FireWire drives, Windows XP detects nothing. Here’s the story so far.

It’s basically never ever worked. Even when the computer was new. Toshiba has no information on their support (what’s that?) site concerning FireWire.

I’ve clean installed with Windows XP Pro with SP2 integrated. My first research attempts way back when SP2 first came out concluded that it was an SP2 problem with FireWire. Nothing would make it budge. I’ve disabled the 1394 Net Adapter, disabled other hardware, installed all of the Intel Chipset Drivers. Nothing. There’s no BIOS setting concerning this port either. I also found this link which explains how to replace the SP2 FireWire drivers with SP1. I did that, and still nothing.

I also clean installed with a Windows XP Pro with SP1 integrated. Nothing still. Unfortunately, I don’t have a version of XP prior to SP1.

At one point, I thought that it might be a physical hardware issue. However, a simple boot to Knoppix 3.6 (Live Linux Distro) proved that theory wrong. It works fine there. FireWire also works fine everywhere else outside of Windows.

I have two optical drives in FireWire cases. They both have Prolific chipsets. I also have one FireWire case with a hard drive in it, which has an Oxford 911 chipset. All three of these work great on my other computer.

Does anyone have a clue what can be done to fix this? I have tried everything that my years of XP troubleshooting and fixing has tought… and I’ve been running XP since original Beta stages! (Legit too).

For those of you out and about on the web, sorry if you see this post on other boards too… I’ve been trying to fix this since last summer.

Thanks!


#2

Maybe a silly question, but if you plug in the hard disc and restart your computer, is it recognised then?


#3

if im not mistaken, the 4pin FW ports aren’t powered whereas the 6pin ones are…perhaps this has something to do with it (though you said they worked fine when you booted to the live linux distro).