Windows XP detects my ND-3520AW as a DVD-ROM drive

vbimport

#1

Hello,

I added an NEC ND-3520AW to my system as a Master drive (slave is a K-Hypermedia CD-RW drive). However Windows XP home has configured it as a DVD-ROM drive so I can’t burn to it. My Nero CD/DVD writing software doesn’t show this drive as a writer.

The following details might help in troubleshooting -

  1. System config - AMD Athlon 2400XP with 512 MB RAM, K-Hypermedia 52X CD-RW drive, NEC ND-3520AW DVD-RW drive, WesternDigital 120 GB hard Drive, Via motherboard with support for IEEE-1394 and USB 2.0, ATI 9600 128MB video card.

  2. Operating system - Windows XP Home (base, no service packs installed).

  3. When I look at the driver details for the ND-3520AW, I see the following four files - cdrom.sys, redbook.sys, imapi.sys, storprop.dll. These are the same files set up for the K-Hypermedia CD-RW drive also (which works fine BTW).

  4. Jumper settings are correct - ND-3520AW is set up as Master and K-Hypermedia is set up as slave on the secondary IDE port.

Any suggestions on how to update my driver so that the DVD-RW will be detected correctly and can be used for burning DVDs? Thanks in advance for all suggestions.

Ajay


#2

Try to delete Ide Controller in Device Manager and reboot. The device will be redetected.


#3

Make sure that imapi service is running. Also did you try burning a dvd with another program?


#4

Thanks for the inputs guys but No luck. I tried both your suggestions -

  1. I uninstalled the Secondary IDE Channel (that controls my optical drives) and rebooted, everything was re-detected and configured as before, i.e., NEC as DVD-ROM and K-Hypermedia as CD-RW.

  2. I then went into ‘Services’ and saw that IMAPI was not started; it was set to manual. So I set it to automatic and started it up manually. I figured I’d do a restart, but upon restarting, I saw that even though IMAPI was set to automatic, it still hadn’t started. So I started it up manually again. However, the NEC drive continued to show up as a DVD-ROM drive.

I also installed another burning program, and the NEC doesn’t show up even in that program as a burner.

Any other suggestions? I’m thinking of moving back to Win 98, will a DVD burner be supported in that? Apart from generic XP drivers, are there any specific drivers I can download for the NEC? Thanks again.


#5

Try change the ide cable w/ a new 80 pin ide cable. Last time I had a similar problem. The computer not even detect my dvd burner. The old cable is come with the TDK cdrw and has been working perfectly with the TDK cdrw. I switch the tdk to slave and connect the nec to master. The computer only detect the tdk. The jumper is set right. But once I change the existing cable with a cheapie 80 pin IDE cable ($1 from computer show). All the problem gone.


#6

It is because you have no Service Pack installed. Just ran in to this today doing a reformat on one of my drives and before I installed SP1 it showed the drives as DVD-Rom’s, after SP1, DVD-RW. Hope this helps.:slight_smile:
BTW. Welcome to CDF.


#7

To late to Edit above post: Could also be the XP HighMat CD support Windows Update as well, I installed so may updates today that I can’t be sure if it was SP1 or the above update but it definatly changed the Drive ID. Sorry about that.


#8

Thanks for the new suggestions guys. Before I try changing cables, I will probably try crossg’s suggestion to install the service packs. One question though - Do I need to install the ‘XP HighMat CD support Windows Update’ after SP1? Will this update show up through win xp’s built in updater or do I need to go to Microsoft’s website and search for this update? Thanks.


#9

It is probably available on Windows Update and you may be able to just select that option to install, I installed SP1 before going to Windows Update (I keep SP1 exe on disc) so I am not sure if it’s available before or after installing the Service Pack. Good Luck.:slight_smile:


#10

did you install the burning software that came with the drive? if not my guess is the drive is not recognized as a burner by nero. you would need to install the nero (most likely 6) that came with the nec to get it recognized


#11

I am having the same problem, Just got my drive today…Seems to burn CD-Rs fine, but only detects it as a DVD-ROM not a DVD-RW…I am also using Nero. I tried 6.0 and 6.6. Im currently trying the HighMAT update to see if that fixes it


#12

I don’t know if I should have started a new thread, but it has to do with windows xp showing the nec 3520a as something weird.

I have 2 computers
#1 P4 3.0ghz, winxp pro sp2, 1 sata hdd, nec 3520a oem (bought it in Jan 2005)
#2 Athlon 64 3200+, winxp pro sp2, 2 sata hdd, nec 3520a oem (from newegg, few weeks ago)

We got comp #1 from cyberpower and I updated the firmware from 1.04 to 3.04 using nec’s official updater. It works fine.

Comp #2 we just put together and there are several observances:

a) in device manager it says:
_NEC DVD_RW ND-3520A SCSI CdRom Device
Device type: DVD/CD-ROM drives
Manufacturer: (Standard CD-ROM drives)
Location: Bus Number 0, Target ID 0, LUN 0

SCSI?!? Why on earth would it say that? I’m using the “cd-rom” ide cable that came with my asus a8v deluxe motherboard. And I’m using the primary ide channel.

b) Dvd shrink freezes right before it is about to burn. You stick it in and it says writing to cache and it just stays there. (the disc is still blank)

c) Nero’s info tool says that it supports dvd+r dl. I thought firmware 1.04 couldn’t do that? In comp #1 nero info tool says it doesn’t have dvd+r dl

d) When i tried flashing to 3.04 with nec’s updater right away it said “Flashing Error.” But I just hit cancel and the drive still is 1.04 and it still works

Do you think that all my problems are due to the fact that it says it’s a SCSI Cdrom Device? How do i fix this? I have succesfully copied a cd using nero, but i haven’t made any dvd’s yet with dvdshrink/nero

Thanks for you patience and help


#13

This is not a problem, depending on the chipset drivers you’re using, sometimes the CD/DVD drives are reported as SCSI. Nothing to be alarmed, since the unit is properly recognised.

This might have something to do with your chipset and the drivers you’re using, since your mobo is quite new (Athlon 64). What chipset do you have and which drivers are you using?

You can try the IDE drivers which came with your mobo, or if you’re using those try the MS default drivers instead. That might clear these problems.

The fact that NERO works, just reinforces what I’ve said … and it is definitely not a problem to have your drive branded as SCSI …


#14

my mobo is asus a8v deluxe which is socket 939 and a via K8T800 pro chipset

the via 4in1’s are installed but ill look around for other stuff


#15

I just want to remind you that it’s currently 1.04 and in nero info tool it says that it has dvd+r dl… how strange

I’m kind of scared to even try flashing to some other firmware. Because the nec updater sure don’t work.


#16

Is that even possible? 1.04 with dvd+r DL? This is driving me nutz.


#17

Yes thats corect v3.04 added support for DVD-R DL
your NEC always supported +R DL


#18

I mean, it’s currently at firmware 1.04, and nero info tool reports that it has dvd+r dl already.

On my other computer, it had 1.04 and nero info tool said that it didn’t support dvd+r dl until i flashed to 3.04


#19

Ok, it’s not the nec 3520a’s fault.

I took the 3520a (f/w 3.04) from my other computer that is working perfectly and stuck it into my problematic machine.

It did the same thing: Dvd shrink freezes right before it starts to burn (disc stays blank).

I’m not really sure how to reinstall the ide drivers like someone mentioned. I don’t know if this is important but I have 2 sata harddrives (not in raid) and I disabled the promise fastrack drivers in the bios and used the via raid drivers from viaarena.com. I am also using the via 4in1 drivers, which i have reinstalled already.
I also tried using the secondary ide channel and the same thing happens.
Also for those that may not have seen, when i tried to use the official nec 3.04 updater i got a “flashing error” right at the beginning (but the drive still seems to work). So something is weird about this computer. I just don’t know what.

asus a8v deluxe (k8t800 pro chipset)
athlon 64 3200 (venice)
4 x 512 corsair valueselect ram = 2gb
windows xp pro service pack 2

Thanks for any ideas.


#20

I’ve told you :slight_smile: The simptoms you describe, look like an IDE driver incompatibility to me … it happens sometime with new chipsets and certain non-MS IDE drivers.

Go to device manager, expand the “IDE/ATAPI controllers” section, right click on the “VIA Bus master controller” or whatever the name is in your case and select Update Driver …

Now the HW Update Wizard appears … select “no, not this time” and click next … now make sure you select “Install from a list or specific location” and click next. Select “Don’t search. I will choose the driver to install” and press next again.

You’ll now see a list of compatible drivers … choose the Standard one (this is the MS default IDE driver) and click next … agree to any questions you might be asked, and after everything is done, make sure you reboot the comp when asked to do so.

That’s it. After you restart your comp the new driver should be the one you’ve just installed (check just in case). Hopefully this will sort out your problem.

Have you used the latest driver from VIA? The latest version is 4.53v. You might as well try the latest Hyperion Pro v5 one as well, if none of the above cures the problem…

This was quite expected I’m afraid …

PS. WRT DVD+R DL support, as clsA said, ALL NEC3520 drives have this support irrespective of their FW version. Why Nero Info tool hasn’t showed that on your first comp I don’t know :confused: