Windows thinks my RAID controller is a NIC

Yesterday I formatted this system and put XP pro with SP2 back on. On my system there are 2 RAID controllers: one by VIA and one Promise controller. The Promise controller installed without a problem, but the VIA one didn’t. Windows keeps detecting a network controller (there is only one NIC in my system but that one is installed and working properly) that it can’t install. I guess that this NIC it detecs is my VIA RAID controller, but I can’t install the drivers (not the ones that came with the board nor the ones I got from VIA’s website). It’s not that big a deal as I don’t use that controller, but it still stinks ;).

Anybody an idea how I can force Windows to recognize the VIA RAID controller?

My mainboard (with everythin on board, except for the VGA) is a MSI K8TNEO FIS2R.

why dont you disable the controlller in the bios if you dont use it ?

  1. Because that would be circumventing the problem rather than finding a solution :wink:

  2. Because I will be using it in the near future as I want to add some drives to my system.

Thanx for reacting anyways!

have you tried removing the existing sata card from the system to see if it can be configured that way?

you never said you would be using it in the future, but for now disabling it easiest solution

This does not surprise me in the least.
It has been widely rumored that the buggy SP2 has hardware dection issues.

It’s an onboard controller, so removing it would damage my mainboard beyond repair. That’s not an option.

Sure I can disable it right now, but that would yield nothing more or less than the current situation: uninstalled.

@Nemesys: good point! Although my former XP installation had SP2 on it as well, I now did an install of a SP2 slipstreamed version of Windows instead of a SP1 slipstream with SP2 later on installed…

Your “VIA RAID Controller” is the SATA controller and the driver you need is this one, http://www.viaarena.com/downloads/drivers/RAID/VIA_RAID_V310E.zip
I highly doubt that it’s a SP2 issue.
//Danne

Tried that driver already… Windows tells me that it’s the wrong driver.

I doubt that, as that’s the only piece of hardware left uninstalled.

Gish I wished there were Linux drivers for my RAID controllers… :frowning:

I also suspect SP2, why didn’t you install with SP1a and see ifit works, then try migrating to SP2, many suggest this and it seems to be a good solution for silly little problems such as this.

Can you post a screenshot of the device manager window (expanded tree)?
//Danne

Sure it is… problem is that I don’t want to spend another evening (during the exam period) to reinstall the whole damn thing over again…

@Dizzy: here’s the screenie with all the relevant informatiom (I guess).


What if you disable the SATA controller in BIOS? Does the Network Controller go away?
//Danne

Just got home and I tried it.

Disabled the RAID in the BIOS -> NIC gone.

Re-enabled the RAID in the BIOS -> NIC still gone, VIA controller installs fine with the latest drivers.

Pretty strange issue… but it’s solved!

Thanx for the troubles everybody!