Windows not recognizing External DVD Burner (NEC ND-3540A)

vbimport

#1

[qanda]This thread is about the NEC ND-3540A. Click here to see full specs[/qanda]I have an NEC-3540 external DVD burner in Plumax USB 2.0 enclosure. When connected to a system running on windows XP or Vista, device manager shows the external drive under USB controllers as USB Storage Adapter AT2(TPP). However i do not see anything under disk management .I do not find the drive in “My computer”. I checked the dvd burner with multiple computers with same result. The USB port on the computers are ok, as if i connect any other thumb drive or a camera they show fine.

The driver details for NEC-3540 in device manager does not show any problem. The driver provider is Cypress and driver date 4/6/2002. In the system tray also i get a icon to show that the device is connected. I have tried re-assigning the drive letters. It does not help.

What could be the issue preventing windows from showing this in My computer as a drive ? Also when i boot the windows XP system with the external drive connected, it will not start. Once i switch off the external drive it would start automatically. The same while shutting down the windows XP system, it would not shut down , till i switch off the external drive.
When i choose to override the manufacturer driver and let windows pick a microsoft driver, the device changes from USB storage Adapter AT(TPP) to USB Mass storage device and would also show under disk drives without any driver.

Any assistance will be highly appreciated. Is the external drive faulty ?


#2

Welcome to the forum. :flower:

Probably the easy way to check the drive itself is ok, is to remove it from the enclosure and connect it directly to an IDE connector inside the PC. If this shows the drive is working, then you may have a software conflict somewhere. But first, we must make sure if the drive is working or not.


#3

Thanks. I am working with a laptop where i do not have full access to open it and connect as an IDE. Any other recommendations ?


#4

Opened the enclosure to find that the pins of the outer enclosure was not connected securely to the burner unit . Once i connected, the drive showed up. thanks


#5

I’m glad you got it working properly and, thanks for letting us know what the problem was.