Windows not recognizing discs

vbimport

#1

Hi, using NEC 3520. If I insert ANY disc, Windows does not recognize the disc, let me elaborate. When disc is first inserted, the mouse turns into a disc icon like normal, signaling that it is reading the disc, ok. Now, normally Windows would prompt me with the AutoRun dialog, asking me what I want to do with the files, now it doesn’t; this is not my main concern, but it is a sign that something has gone wrong. MAINLY, I am concerned with the fact that in Windows Explorer, the name and icon for the DVD-RW drive does not update with the name of the disc after the disc has been loaded, it simply still says “DVD-RW Drive” instead of the name of the disc. I can still access the files on the disc, so that is okay, but the name and autorun don’t work.

Let me tell you that this has happened to ALL of my systems, on ALL operating systems, NUMEROUS times, this exact same thing, it just hasn’t happened to me for a couple of years. A fresh install of Windows has ALWAYS fixed it; I would like to know a real cause or solution.

To solve the problem I tried the following things:

  1. Checked registry for Autorun setting; it is on.
  2. Tried turning Autorun off in Registry, and then turning it back on (worth a try)
  3. Changed IDE cables for the drive.
  4. Rebooted Windows without the drive connected to IDE, shut down, reconnected IDE (uninstall, reinstall drive)

Nothing has worked. What the hell is this and do any of you have the same annoying problems that I do?

Thanks


#2

I had a problem like that before. Some discs would read the name of the discs and other times it wouldn’t show the disc name. I didn’t care as long as I could get the data off of my disc. I never found out the solution to the problem. But, now I have Vista Ultimate, and it reads all the names of the disc for me so far. Couldn’t be more happier than that. :slight_smile: The only thing I can think of back then was:

  1. It depends on the program you burned the disc with
  2. The DVD drive didn’t want to read the disc name
  3. Too many burning programs installed
  4. Other software conflicts
  5. OS SP1/SP2 updates/ software update conflict
    Otherwise I could live without having a name being displayed on the DVD-RW. Oh, and I hate the autoplay and autorun features. It’s annoying.

#3

You can turn it off. You can turn it off for external hard drives also, at least with XP Pro. I have an external hard drive with 4 partitions, and I would get 4 copies of that autoplay window popping up at the same time.

XP Pro disable:
http://dougknox.com/xp/tips/cd_autoplay_pro.htm

XP Home disable:
http://dougknox.com/xp/scripts_desc/xp_cd_autorun.htm


#4

MicroSoft’s TweakUI (Powertoys) is very user friendly for this type of thing plus many others. Definitely a handy tool to have.


#5

Just to add to the conundrum, Windows Elplorer won’t read a certain disk AT ALL. But Isobuster completely recognizes the disc and can read files. Hmmm.


#6

You may have guessed it.Check this out http://support.microsoft.com/kb/883523/en-us it applies to DVD writers as well.It cured all my issues when installed the hotfix.Hey! try rolling back to SP1.(hint)


#7

This started happening to me about a month ago. My fix was to boot into safe mode. Uninstall the 3520a. Reboot into normal windows and let the plug n play reinstall and it works again. It usually works again for a wee and then it does it again. Could this be some sort of root kit that is disabling the drive?


#8

This is a very interesting thread. I myself have been having problems recently with my drive as well. I have two DVD+/-RW drives in my PC…Primary drive is a Lite-On Atapi DC and secondary is an HP Lightscribe DVD Writer 720b. I’ve had problems with the HP 720b since day one…It would only burn CD-R’s & Lightscribe labels but NEVER a DVD. The Lite-On has burned many CD’s and DVD’s for me over the years until here recently. I can back-up as many DVD’s as I want but the drive absolutely will not recognize a CD. Store-bought CD’s, Blank CD-R’s or previouly burned CD-R’s…None of them are recognized. I tried to fire up the old HP but shocked to find that all of a sudden even it won’t recognize ANY kind of disc. I’m thinking about trying what scrappy3111 just described.


#9

[QUOTE=sumpm1;1694610]Just to add to the conundrum, Windows Elplorer won’t read a certain disk AT ALL. But Isobuster completely recognizes the disc and can read files. Hmmm.[/QUOTE]

Then there could be a OS driver/3rd party driver problem.


#10

I have the same prob but it only recently started with the new discs that wouldn’t work with certain software. I’ve never had a prob reading or burning any cds or dvds… until “Day Watch”, “Saw 4”, & “Yuma 3:10”. my drive just spins forever and will not recognize the disc. No info comes up in xplorer, nothing. Its as if I had inserted a blank, badly damaged disc although they are brand new. Its gotta be the new code being put on the new discs so I believe I’ll have to buy a new drive because the discs worked fine on my st-top DVD player and a friends laptop DVD drive.:a


#11

It seems you may have joined many other NEC users with a common affliction detailed at http://club.cdfreaks.com/f86/nec-optiarc-dvd-r-reading-problems-209168/. As stated in that thread ISOBuster and a few other programs read such disks while Windows fails to read them.


#12

Hi, bevills1

I don’t hav a NEC drive.
And I may be being incredibly stupid but if u hav a windows OS then no matter what drive u have, if windows wont read it, ur outta luck. I hav a Phillips, and yes I’ve checked those threads. The link u provided discusses data discs reading as empty or as other kinds of media. my drive spins endlessly and no info pops up anywhere about the disc in the drive. Maybe its the drive…maybe its the OS.

Thanx for the help but alas, my drive, as mentioned earlier is NOT a NEC drive.:bigsmile:


#13

My reply in post #11 was in response to OP’s post #5. The shidoshi problem not seeing blank discs could be bad or incompatible media. Does ISOBuster see blank discs, and has other media been tried? You might try removing the DVD drive under hardware, reboot to have Windows detect the drive and see if that helps.


#14

Hi I am new to this site and I am having the same problems as you guys …DVD Drive Reads CD as RAW?


Every blank disc I insert…my computer shows that it has 0 free space and 0 total space… I am using xp home and a sony DVD burner anyone help me with this ?