Windows Media Player not playing mpg properly anymore

vbimport

#1

My WMP (in Vista Ultimate 64) doesn’t play my mpg movies. It freezes the frames but the sound seems to be “sort-of” OK. It worked before, but now it doesn’t anymore. Anyone experience this? How do you fix it?


#2

Try VLC Media Player.


#3

Is there something wrong with WMP though? Its not so much that I want to be able to play the mpg (I know the files is still good), but I just want to find out what had caused my WMP to stop behaving the same.


#4

I do not know about Vista, but I gave up on WMP with WinXP.
It will play commercial DVD, but get stuck on anything burned, since version 11. Tried to go back, but it did not work any more???


#5

rasmasyean;This may not be your problem but I have Vista 32 & I installed this software : Avi2Dvd.
WMP 11 stoped playing .mpg,.avi & .mpeg once I uinstalled the program it worked again.So if you have it you might want to uninstall it.It might be another program that installs a codec this program did.I’m don’t know what codec it was though.
Other than that you may have a missing or corrupt codec .Some software puts in it’s own version of a codec then when uninstalled it removes its version without replaceing the old one.
I haven’t tried it but I believe there is a MS Vista codec pack.


#6

Actually I installed Adobe CS3. And I think after I installed it, it probably didn’t work anymore. Unless my faulty memory is making this up just to find an explaination. So maybe when I installed Premier from Adobe, it did what you said. I also tried some mpgs from the internet and they seemed to work. My particular mpgs were made by Nero some time in the past. Perhaps it’s a different Nero mpg encoder spec???


#7

If the version of Nero used a codec that Vista or WMP 11 doesn’t have or the “Nero” codec they have is corrupt that’s where the problem should be.
You might try VLC player.
I haven’t tried but maybe you could reinstall WMP 11 & see if that fixes the problem.


#8

I tried VLC and it works thanks.

I also noticed that Premier cannot import my mpgs properly but can import those I found on the internet. I suppose Adobe is picky on the MPEG 2 “variant” they support. Maybe it has their own little twist on it. Because, in addition to my Nero created mpgs, files from my Toshiba DVD-RAM recorder don’t work. Normally, I just rename the large file in the DVD-RAM to .mpg and it would play in WMP, but Adobe seemed to have messed that up.

Maybe Adobe just wants to reduce support for some MPEG2 specs for their own reasons. I would imagine that a company like Adobe wouldn’t “accidentally” miss these codecs.