Windows keeps on reverting back to PIO mode

vbimport

#1

Some time ago I installed a computer based on an Asus A8V Deluxe-E mainboard (VIA K8T800 chipset). Since the installation of this system, Windows has problems with getting into UDMA mode. It only goes into UDMA mode when using the VIA 4-in-1 drivers that came with the mainboard; newer drivers only seem to do PIO mode. And, every once in a while, the system falls back into PIO mode. By deleting the IDE channels and rebooting, everything goes back to DMA again. As this happens twice of three times a week, it’s quite frustrating.

Question is: how to fix this? Is there any way (reg hack for example) to force Windows to go into DMA mode? Not it displays that DMA is not available, only PIO mode…


#2

How about this?
If not a maybe a reinstall of windows?

\\VH////
:slight_smile:


#3

Yeah already tried that hack, doesn’t seem to be effective though…

Reinstall is not a good option, as this would require the reinstallation of heaps of software :frowning:

Thanks anyway :slight_smile:


#4

it could be that the onboard IDE controller is defective. if this is a new board I would consider RMA.


#5

Well that’s what I thought at first, but as far as I can tell, it is alright.

Why? In Windows, the problem only occurs after changing something to the system (for isntance, installing some program). In Linux, there is not a single problem at all, it works like a charm. This makes me believe it is a software issue.

If you think I am wrong, I’d be very glad to hear so… stupid problems like these… well… euh… I don’t like’em :smiley:


#6

was this a clean install of windows on this board? if it wasnt then it is probably a problem with the HAL.


#7

Yes, that’s when the problem first appeared.

At first it didn’t seem to be severe, but not it seems that it keeps returning more and more often…

What can you advice me to do (besides a clean install)?


#8

I guess this is why your an administrrator no easy to fix problems you got to bring us a mystery…lol. ok here are some of the things I would do.

  1. run system file checker. I am assuming you are running XP you will need your XP disk.

with your XP disk in the drive open a command prompt and type: sfc /scannow
this will check windows system files for corrupt or missing files and if it finds any it will repair or replace them.

  1. how about your bios? are you using the latest bios for your board?

  2. it could be one device ( optical or hard drive) that is causing the problem but with the occurances be intermitent this is difficult to pin down. I once had intermitent system problems I finally traced down to a defective flopppy drive.

Good Luck


#9

I had the problem with the 4 in 1 version 4.55, went back to the 4.53, these seem to be the best set so far.

Is the bios current?


#10

Thanks :slight_smile:

  1. Didn’t even know that option existed. Next time the problem appears, I’ll try that one :slight_smile:

  2. Yep, the latest BIOS version is on!

  3. I figured that could not be the case here. The harddrive that always falls back to PIO mode is the only one on the channel (primary master). As the same harddrive is used in Linux without a problem, I think there is nothing wrong there.

Thanks again!


#11

Yeah the bios is current. And I’m indeed using the 4.53 drivers right now as the 4.55 where the ones giving problems.


#12

i remember seeing a tip about raising the error threshold in windows to a higher limit so that it wouldn’t revert to PIO mode so often. i’ll try to take a look for it.


#13

Are you perhaps referring to the KB article VirusHack linked to?


#14

it could just be the via drivers since you indicate that this problems occurs with the latest set. sad to say via has been having a terrible problem with their drivers for the past year or so I quit updating to the latest ones over a year ago because of the problems caused by the newer ones. And whatever you do DONT even think about installing the new Via IDE accelerator drivers they are serious bad news.


#15

Iv got the latest VIA 4-in-1 driver pack install and I not having any probs with DMA/PIO or anything eles. (KT400 chipset here)

\\VH////
:slight_smile:


#16

Me neither on my K8t800 pro board (MSI)…


#17

Don’t know if this works but have you tried this? Change from .txt to a .reg file. Back-up registry of course.


#18

i didn’t read VH’s article so i’m not sure. it was a manual registry hack if i remember correctly.