Windows keeps changing DMA to PIO (Lite-On DH-20A4H)

[qanda]This thread is about the Lite-On DH-20A4H. Click here to see full specs[/qanda]Hi,

This is my first post on this site, and I am not particularly technologically minded, so straight off let me apologise in advance for any stupid questions/foolish errors that I will make! Please bear with me!

My problem is to do with a new DVD drive I have installed. My computer is a Dell Dimension 5150 and it has 2 DVD/CD drives, for which I had been using one to rip information and the second to burn it to a new dvd. One of the drives stopped working recently so I bought a Lite-On DH-20A4H DVD RW RAM drive to replace it. I took out the old drive and put the new one in myself. My problem now is that it takes far longer to burn a new dvd, whereas with the old drives it took about 20 minutes.

I searched this site for some answers and found some information about DMA mode and PIO mode, and how PIO is much slower. I checked my device manager and, sure enough, windows has switched me to PIO. I followed all the prompts on this site to switch it back to DMA, but every time I try to burn a disk it switches it back to PIO. The first 4 or 5 minutes it burns really quickly, like it used to, then it slows down and when I check it has gone to PIO.

I have tried a few things. I have switched the DVD drives around to see if that helps, but no. I have uninstalled the Primary IDE channel and then rebooted for windows to try and install it again, but the same thing happens. It starts out on DMA but switches to PIO after about 4 minutes.

I have even followed a thread which talked about typing regedit into the run box, but to be honest I didn’t really understand what to do on this, so couldn’t follow it through.

Does anybody have any advice as to how I can get my computer back to DMA for good, so that burning DVD’s does not take hours on end?

Many thanks!

Welcome to the forum :slight_smile:

Maybe you have a faulty IDE cable. Try to get a new cable, and be sure to use a 80 wires cable :slight_smile:

Hi gavilav, welcome to CDFreaks! :slight_smile:

Try reading this article on DMD reverting to PIO:

http://winhlp.com/node/10

Hi Drage master!

Thanks for the link, but I am not sure if I am using it right.

It takes me to a site which says if you want a quick fix and don’t care to find out what caused it (Which I would love!!!) then click on a link. I do this but it brings me to a page of text, which is a Visual Basic Script program. Do i try to run this program? How do I do that? If this link can switch me back to DMA permanently then the job is done.

Thanks geno888, but I’m guessing the cable is ok, as I have had no problems with burning until I switched drives. Plus, I know it is switching to PIO which everyone I have read on this site seems to say contributes to slow burning.

Nothing will permanently set your adapter to DMA mode, since Windows has a mechanism for automatically degrading the mode in steps towards PIO when problems are encountered.

The linked page contains an explanation of why it happens, how to fix it temporarily, and what to do to decrease the sensitivity of your adapter so as to reduce the chance of DMA degrading to PIO again.

I see what you mean Drage. Thanks for the link.

Having read it all I think, now though, my problem is not switching back from PIO to DMA. I can do this fairly easily. It’s just that the next time I go to burn a disk, it switches back to PIO after a few minutes and I am faced with the long wait again, and the constant rebooting to switch it back from PIO to DMA. I am really confused.

I guess I am trying to figure out what it is that is causing my system to switch from DMA to PIO and then do something to stop this happening, or at least reduce it. I’m confused even more by the fact that it didn’t do this at all before I replaced the dvd drive. Any ideas?

Try replacing the cable with another 80-wire IDE cable as suggested by geno888.

A frequent cause of reverting in PIO mode is when there are too many errors in data transfer. A damaged cable can be a cause of this, so I again suggest to try a new cable to see if it solve :slight_smile:

also try this

It seems like trying this new cable might be the thing to try. I have uninstalled and reinstalled the drives and each time I start out burning the dvd with DMA enabled but it soon switches to PIO. Maybe the old cable is a 40 wire one that cannot keep up with the new faster burner? Does this sound like it might be right?

If I do order a new cable, do I need to look out for anything specific? And how easy are they to fit? What should I be looking out for?

Thanks!

Here is the difference between the two types of IDE cables. Very easy to replace. Just make sure the blue end connects to the motherboard. If your current cable attaches to the drive on the very end connector, then make sure you do the same with the replacement. If it is on the middle connector, attach it there on the new one.



Hi,[quote=gavilav;2150229]It seems like trying this new cable might be the thing to try. [/quote]Trying a new cable is always a good idea :slight_smile:

If I do order a new cable, do I need to look out for anything specific?
You need an UDMA-4 capable cable (these have connectors in three colors, and the wires are rather fine. Flat ribbon, length: 18" (45cm). No rounded, and no longer cables. Maybe the computer store round the corner is the better source.

And how easy are they to fit?
Rather easy. But be careful to not damage the pins of one the connectors (on the mainboard or the drive side). The blue connector of the cable ist to be plugged into the mainboard connector, the black connector belongs to the drive which is configured as Master, the grey connector is for a second drive.

Michael

EDIT: Kerry56 was faster :slight_smile:

By the way, most all the newer IDE cables I’ve seen have the motherboard connector differentiated by making it a blue color. If yours doesn’t have that, don’t sweat it. It will probably be marked as the motherboard connection in some other way.

I have uninstalled the Primary IDE channel and then rebooted

the link instructed to uninstall the ide controller, only uninstalling the channel may not be enough.

however i think the best thing you can do now is get a new cable, you should be able to get one locally at electronics stores. also check the pins on the drive for possible damage.

edit// the two drive connections are placed close together and the motherboard is the lonely connector at the other end.