Windows installing wrong drivers?

vbimport

#1

I received an Asus CRW-4824A (CD-RW drive) as a gift from someone. It has weird problems, such as not being able to read most CD-Rs and CD-RWs (except Sony’s, ironically) and it now can’t read those Sony CDs after it burned them.

I know I had a similar problem with another one of my drives (BTC DVD-ROM drive) in that it couldn’t read some discs. I solved that problem by updating the firmware on the DVD-ROM drive. Now it reads all kinds of discs.

So, I tried to do this with my Asus, except the Asus auto update program says I don’t have an Asus drives installed. :a I notice that Windows shows my CD drive as a CRW-4824AH, but the firmware update is for a CRW-4824A. I’ve checked everywhere, and apparently, a CRW-4824AH doesn’t exist. :eek: I can’t find any firmware or driver updates for a 4824AH, though I find plenty for a 4824A.

If that isn’t enough, the drive itself (the label on top) indicates it is a CRW-4824A, not AH. So something screwy is going on… is Windows installing the wrong drivers or something?


#2

I realize this is a rather old post, and I apologize for bumping it, but I am having a very similar problem at the moment. I can’t find any updates for 4824AH, and when I try and use 4824A updates, they of course do not work.

I would really like some help with this.