Windows explorer crashes when starting Avi or just pointing the cursor over the Avi f

Windows explorer crashes when starting Avi or just pointing the cursor over the Avi files and sometimes even opening the folder containing files (different movie) results in crashing of the explorer. Some video files (video clips which i cut from some movies) also makes the windows very slow. I have tried to repair them by All Media Fixer but the problem remains the same. Please help!!!

I had this exact same problem with explorer crashing & I found that it was a corrupt Xvid file. I seem to remember that I deleted the xvid*.* files in the system32 directory & reinstalled a new version, not from one of these codec packs.
Hope this helps.

Hi,

If this happens for more than one Avi file format(more than one codec) then I would do the following :

http://personal-computer-tutor.com/abc3/v31/vic31.htm

I used to get a lot of errors with avi files till I saw the above. Please note that if you are not comfortable with programming/editing the registry then please ignore this as you could render your computer useless.

If the problem is only with a single codec then it is most likely corrupt and a re-install of the problem codec(alone) should do the trick.

Hope this helps.

2 things you can try

Hi

bit late to the party - however. I was having the same problem with mpegs. Certain mpegs would crash explorer. To start with al I needed to do was [U]open the folder that contained [/U]the files and [U]windows explorer would crash. [/U]
You can get it to stop crashing as soon as you open the folder by [U]turning off thumbnail cacheing. [/U]
To do this


Open windows explorer on a freindly non-crashing folder and go to tools> folder options >view >check Do not cache thumbnails - [Apply to All Folders]


however I was left with another lesser problem. Everytime I [U]clicked on the file windows explorer would crash[/U]. I was not playing or anything just highlighting with windows explorer. What solved this problem for me was [U]unregistering media preview[/U].

to do this


Open the ‘Run’ dialog box from the start menu (Start->Run or press the Windows and r keys together):

To remove media preview, type and hit enter
regsvr32 /u shmedia.dll
To readd media preview, type and hit enter
regsvr32 shmedia.dll


a bit of waffle

This method is more of a work around than a solution.
I knew it wasn’t a virus as the computer hadn’t been connected to the internet. My understanding is that when you click on a media file with explorer it tries to create a preview. If explorer can’t create a preview for what ever reason it crashes ( instead of say moving on ). By unregistering this capability you prevent it from even trying and therefore prevent it from crashing. However unregistering media preview limits the amount of information exporer can give you about a media file - ie length, dimension, bit rate etc. This has no effect on windows media player capabilities (or lack of them) and explorer can still display overall file size. It is also a reversalble process

nb all original spelling mistakes are the copyright and intellectual property of yourpotential-ourcrashing YOU HAVE BEEN WARNED!!

Windows Explorer was crashing when I would open or just mouse over certain avi files. Thanks to the post above from "yourpotential-ourcrashing"
I was able to fix this problem, which was driving me nuts for the last 5 days.

Here’s what worked for me:

Open windows explorer on a freindly non-crashing folder and go to tools> folder options >view >check restore defaults.

(now Windows explorer only crashed when I would open the file itself)

Then I ran from the run command:
start->run->regsvr32 /u shmedia.dll

Now everything is working normally - don’t know what I installed that changed this but the fix worked!

Hope this helps someone - for more details, see the previous post from “yourpotential-ourcrashing”

1-11-09

I was having the problem of explorer crashing when pointing to any avi file and did try the fix suggested here by removing media preview
"regsvr32 /u shmedia.dll"

It did solve the problem of explorer crashing, but unfortunately WM Player will not play the files now. I tried changing the file association from WM to Real but with no success at all.

I would appreciate any other suggestions that might help.

WMP is crap.

Either tr VLC or MP classic.

I solved this problem of Explorer crashing when attempting to rename and AVI file by deleting the K-Lite Codec pack which I’d installed when upgrading to VideoMach Pro 5 from http://www.gromada.com

I haven’t tried VideoMach Pro 5 since deleting above so I’ll have to solve that when I come to it or go back to the previous version of VideoMach I was using which is no big deal as converting certain AVIs with VM would result in synch problems (which VM claims are K-Lite problems)…

I’d avoid any “codecpacks” if I were you. :wink:

[QUOTE=chef;2265576]I’d avoid any “codecpacks” if I were you. ;)[/QUOTE]

Can you explain why you choose to do that?

It should be already clear…

These packs only bring you problems.

[QUOTE=chef;2265858]It should be already clear…

These packs only bring you problems.[/QUOTE]

No it ISN’T clear - after using computers for a looooooong time, this is the first time a codec has caused me any problems at all.

Reasons are very useful, your posts aren’t helpful at all.

[QUOTE=car67;2266591]No it ISN’T clear - after using computers for a looooooong time, this is the first time a codec has caused me any problems at all.

Reasons are very useful, your posts aren’t helpful at all.[/QUOTE]

But yours are or what? LOL!

ASK those who created that movies you have tried…then we can talk again. :bigsmile:

[QUOTE=chef;2266750]But yours are or what?

Go playing, ignorant. :bigsmile:[/QUOTE]

It’s ironic that you call me “ignorant” because that’s exactly what you and your pointless replies are.

Your posts are useless throw-away junk and answer nothing. I don’t need you to tell me what I should or shouldn’t use just because of your choice.

My “reason”? My post was to explain for the benefit of others how I solved an issue that they may experience. Deal with it.

I’ll “go playing” now. Pillock.

“Yourpotential-ourcrashing” did a great job of solving my same problem! (See way back up in Reply #4) Thank you!

(As to this ensuing arguement—why don’t you two just take it outside :slight_smile:

I haven’t follow the whole thread. But I was suffering problems with MKV files
I just want to share me experience:
I simply remove the most disgusting and annoying application: Real Player.
I was searching why in Firefox suddenly all titles changed to Chinese or Japanese… another user suggest to remove Real Player… so I did that.
And by extension… [B]this solve my problems with MKV files![/B]… and disappear some disgusting messages from Real. Gosh I really hate this application

The solution I tried from another forum seemed far out of context “Explorer crashes when right-clicking context menu”.

However it solved this particular problem opening folders, I even restarted to test it.

Here are two possibilities:

Navigated to HKEY_CLASSES_ROOT*\shellex
I clicked the “context menu handlers” subkey and removed all suspicious keys (ones I didn’t use for antivirus or extraction utilities).

HKEY_CLASSES_ROOT*\shell\Media Info <-- this subkey is affiliated with the k-lite codec pack, and could have contributed to the crash, I deleted this value as well.

A million thanks to several of you folks whose posts helped me to solve this pesky problem which had been frustrating me for many months. In my case, Windows Explorer was crashing after exploring to folders containing .mvi files.

Thank you to yourpotential-ourcrashing, JamesTKirk, severant2 and anyone else I may have missed.

I am very grateful! :iagree:

You did mean avi, right? :wink:

[QUOTE=chef;2544350]You did mean avi, right? ;)[/QUOTE]

Yes, I did mean avi - sorry about that! :o Most of my avi filenames [I]begin[/I] with the letters MVI (movies/videos from my Canon digital camera) and that’s what I typed by mistake…

Interestingly, I had originally thought that the Windows explorer crashing problem was due to my .jpg thumbnails. It wasn’t until I found this forum that I was pointed in the right direction. Thank you!!