Windows doesn't recognize DVDs anymore

vbimport

#1

This is a very strange problem. A week ago, I was using ImgBurn to burn DVDs, and everything was working fine. But then a few days ago, I decided to install CDBurnerXP (while still keeping ImgBurn on the system), and now things are messed up.

Both ImgBurn and CDBurnerXP are able to burn DVDs successfully right now, because I can take those discs and put them into a different computer, and the discs are recognized fine. But when I put the discs into the same computer that burned them, and I try to click on the drive in Windows Explorer, I get a “E:\ is not accessible. Access is denied” error.

So the drive still burns OK, but Windows won’t recognize the discs. In fact, if I put any DVD into the drive, including a DVD movie I bought from the store, Windows won’t recognize it. Things were working fine before I installed CDBurnerXP, so I think CDBurnerXP messed something up on the system.

I have tried uninstalling the DVD burner in the Device Manager, rebooting, and Windows reinstalls the driver, but Windows still doesn’t recognize any DVDs I put in the drive. Any idea what might be wrong?


#2

Try removing upper and lower filters. You can do this in ImgBurn by clicking Tools–>Filter Driver Load Order. Click on the filters it shows and delete them. Reboot.

If this doesn’t help, remove filters manually in the registry: http://pcsupport.about.com/od/driverssupport/ht/upperfilters-lowerfilters.htm


#3

My ImgBurn is only showing one Upper Device Filter, for C:\WINNT\system32\drivers\redbook.sys, a Microsoft driver. But looking at the other link you provided, and some other sites I came across, it’s the {4D36E965-E325-11CE-BFC1-08002BE10318} registry key that’s important, and my registry key doesn’t have any UpperFilters or LowerFilters in it. So I’m not sure it’s safe to delete the redbook one.


#4

Don’t delete the redbook.sys
The redbook.sys isn’t going to be here anyway:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}

In addition to what Kerry56 posted .
If you have AnyDVD or AnyDVDHD you may need to run the install again after you remove those filters.
You might see if Shell Hardware Detection is set to “Automatic” in Services.

There are a few registry settings that can be done if the above fails .
They are less likely & I think just for CDs.


#5

OK, so I shouldn’t delete the redbook.sys one, and there’s no other upper/lower filters I can delete.

I also don’t have AnyDVD or AnyDVDHD installed.

What are the other registry settings you mentioned?


#6

If you have a restore point made prior to the start of your issues, try rolling back to it.


#7

Check this also:
Shell Hardware Detection is set to “Automatic” in Services

The registry settings are in this MS article as well as checking for the "Recording "tab.
http://support.microsoft.com/kb/316529


#8

Seems like some sort of permission deep in the OS got changed to deny read access to the drive for Administrator and other users, but somehow both CDBurnerXP and ImgBurn could still burn and read from the drive. I found out Windows actually was recognizing discs that I put in - when I put in a music CD, the drive icon in Explorer changed to a music icon. So it was recognizing the discs, it just wouldn’t let me read them. I fixed the problem by running this program I have called Nero BurnRights to reset the permissions.


#9

Thanks for the update and the explanation of how you fixed the problem. I’ve not seen Nero BurnRights before, but looking at their website, it seems to be limited to 32bit systems, and no operating systems beyond XP and Vista.


#10

Kerry , I have Nero Burn rights installed.
So it’s in the Programs list.
The NeroBurnRights.exe for it is in the Nero Tool Kit folder .
This is in the Nero/Nero 7 Folder In Program Files .
I wouldn’t have thought of using it to fix this problem though.