Windows can't read disk

Hello,

I have a dvd-r disk i made with different file types on it (movie, picture, text) It was working fine. The last time it was opened it worked fine. Now when i try to open it, it tells me windows can’t access the disk. It recognizes that there’s information on the disk, about 4gig disk, and it shows 2.07 gigs are being used. So it sees that there is information on the disk it just says it cant access it. I’ve tried to finalize the disk in hope it would work, but it tells me it cant access the disk still.

Is there any way to figure out whats keeping the disk from being accessable or any kind of tools to fix any errors on the disk or possably back up the files on the disk if the disk itself may be junk? I really cant lose this disk. Please help. :sad:

Hi and Welcome!

some blank media (like Ritek G05) are known for degradation, this could have happened with the disc in question.
You may try if you can recover some data using different drives.

If you have other discs of the same brand or manufacturer, you should backup them as soon as possible.

Michael