Windows cannot recover master file table (TrueCrypt)

[qanda]This thread is about the Western digital WD7500AACS Caviar Green Hard drive. Click here to see full specs[/qanda]Hello!

I bought a new HD a few weeks ago. I partioned it in Windows Vista x64 to one big partition (1000 GB). Then I used TrueCrypt to encrypt the volume. Worked fine, but earlier today Windows was acting weird, the mouse started to freeze at random, so I turned off the computer using Start>Shut Down (I did not force the power off). Then I moved the disk to a Windows Server 2003 x86 server where it should be, I mounted the disk fine. But when I double click it in “My Computer” I get:

“E:\ is not accessible
The disk structure is corrupted and unreadable.”

The disk listed in “My Computer” has “Local Disk (E:)” as volume label, and it is blank under “Total Size” and “Free Space”.

I tried bringing it back to Vista, where I can’t even access it or get the error message. If I start cmd and type “e:” to change to the disk it just waits forever and nothing happens. If I go to “My Computer” in Vista the Window stops responding and show nothing. The mouse started freezing at random also, something that it does not do when I don’t have the disk plugged into Vista (without the disk plugged in I can also access My Computer).

So I moved the disk back to Windows Server 2003, made a backup of the volume header and then mounted it and clicked on “Repair Filesystem” from TrueCrypt. Also later tried running “chkdsk e: /F” from cmd. This is what I got from both those cases:

"The type of the file system is NTFS.
Volume label is STORAGE.
Corrupt master file table. Windows will attempt to recover master file table from disk.

Windows cannot recover master file table. CHKDSK aborted."

What do I do now? The files are critical on the disk, and the only reason they AREN’T backed up is because I’ve had problems with the server and had to use the disk on vista.

I found this:

http://www.cgsecurity.org/wiki/Recover_a_TrueCrypt_Volume#Corrupted_Standard_Volume_filesystem

It’s a small tutorial of how to fix the problem I’m having with an application named “TestDisk”, however when I ran it I became unsure of what to actually select. First of all the interface isn’t that great, it’s DOS-like. Second, the tutorial says “None” should be selected for partition type, but a note inside the programs says “Do NOT select ‘None’ for media with only one partition. It’s very rare for a drive to be ‘Non-partitioned’.” My HD has one partition, and I have encrypted that partition with TrueCrypt, so I shouldn’t select “None”? Maybe the tutorial on the wiki was written for when you encrypt the disk without any partition? Has anybody used TestDisk before and know what I should do?

Please help, I swear to God I will be a better person if you see me through this. If the content of the drive is lost an entire months work is gone by a lot of people (many man-hours).

If you have any questions what-so ever, maybe I have been unclear, please let me know. Thank you for your time!

Download the Ubuntu Live CD, mount the volume & try to pull the files off.
If that doesn’t work, you can unmount it, and run the partition checker.
Might be a tad more robust than windows … maybe.

When HDD in Vista compu reboot with TrueCrypt Rescue Disk in your CD/DVD drive. :wink:
“In the Rescue Disk screen, select [I]Repair Options > Restore TrueCrypt Boot Loader.[/I] Then press ‘Y’ to confirm the action, remove the Rescue Disk from your CD/DVD drive and restart your computer.”.

Note. TrueCrypt is a very powerful program that has to be used with big precaution…
You better take your time and read up guides and manuals linked above.

I’m in progress of restoring the backup right now, but the corrupted drive is still available for fixing. I’ll try GetDataBack once (which will probably not work), guess I should try Ubuntu Live CD also however I did attempt one of those rescue cds which was bugged or something, didnt do anything.

ValHall64: A TrueCrypt Rescue Disk sounds wonderful, however I don’t have one. Seems like you only make one of those when you encrypt the operating system. Can one be made now and will it be able to help me? Would seem like it requires to be made before anything happens to the drive.

R.I.P Hard Drive

I scanned the disk using GetDataBack, got a bunch of errors about that it could not be read sometimes, but you could continue. It found around 200000 “file starts” (I think it was) so it seemed promising. Six hours later it was done and showed… no results. Well that didn’t work, I thought and started TrueCrypt to format the drive. But the drive was not mounted anylonger. Nor could I mount it, it wasn’t in the list. Windows’ “Disk Management” gave no trace of the disk neither. It was gone.

Rebooted and after a little while extra time it said "IDE Channel 2 Master : " and nothing more. Usually it says “None” if nothing is plugged in on that channel but here it said “”. It found something but couldn’t decide what the heck it is.

I’ll have to send this disk back, shouldn’t be this way after only a couple of weeks.

The end.

Have you auto-detected the HDD in bios?
I’d expect Sata HDD parameters to be auto-detected fine … but you never know …

Tis a bummer if the HDD has failed after a few weeks.
Been there, done that … back in the days of 120GB HDD’s.

My 2x80GB maxtors raid array was playing up (bad raid controller driver in a WinXP auto-update it turned out), and I moved everything valuable across to a shiny new WD 120GB HDD … which waited for the opportune moment to break down, immediately after I’d just formatted the raid array & was ready to put everything back on.