Windows 8 question

Hello Everyone,

Just like to share I upgraded to Windows8 this week and installed latest version of VeloSSD downloaded from elitebytes.com.

When I try to launch it nothing happens, not even an error! Tried reinstalling/Run as administrator with no success. Need your help.

regards

Hello,

Just to add, VeloSSD Disc Filter doesn’t appear in device manager as well.

thanks!

I’ve moved your question to a forum monitored by the author of VeloSSD

Please be more specific, i mean VeloSSD works with Windows 8.
What did you do ?
-run VeloSSD2012setup.exe ?

Hi,

  • I ran VeloSSD2012setup.exe.
  • No error encountered during install
  • When I launch VeloSSD 2012 application nothing happens.

I added a remark that I don’t see VeloSSD disc filter in device manager after installation.

Let me know if you need more info

You could add informations about what you did with that computer before you installed VeloSSD. Maybe you have found a way to tweak your system and provoke
that behaviour. This software has been positively tested on lots of windows 8 installations. I recommend changing this threads title, because it is misleading.
I hope you don´t mind that.

Worked fine for me on Win8 64bit.:slight_smile:

I had the same thing as this guy. Driver does not install when you run the setup. Maybe could pm me and do a remote desktop my system to found out whats wrong.