Windows 8 and 720p native TV / projector hiccups and workarounds

vbimport

#1

Up until recently, I have had my projector (a Panasonic PT-AE500E) connected to my desktop. I bought the projector in 2004 back when 40" TVs had 4 digit price tags that didn’t start with ‘1’, particularly anything anything capable of showing even 720p natively.

Over the years, Windows XP and 7 generally worked fine with the projector. With Windows XP I had to manually switch display in the display settings and change resolution to 1280 x 720 to match the projector’s native resolution. Windows 7 was very straight forward - I simply switched on the projector and it automatically switched display and even switched to the native resolution.

After a recent laptop purchase and a clean Windows 8 installation on it, I decided to try out the laptop with external displays, first starting with the living room TV. I got a HDMI cable and DisplayPort adapter and once I switched to the HDMI input, the picture showed up fine in 1920 x 1080 to match the TV. I performed a quick video test to make sure the video and sound worked fine and then took the laptop to my room try it on the projector. Well, things didn’t go quite straight forward in Windows 8… :disagree:

With the projector connected, I pressed the Fn-combination to switch output, but got nothing. I then tried clone display and this time got a rather odd resolution of 1280x768 on the laptop and still no output on the projector. This didn’t really surprise me as the projector doesn’t support 1280x768. Worse still, Windows only gave three resolution choices - 1024x768, 1280x768 and 1280x800. When I tried 1024x768, I finally got a picture, but rather distorted (4:3 -> 16:9) and blurry due to the resolution mismatch. :doh:

After some further tinkering, I decided to go into the Advanced Settings and into “List All Modes”. At last I got 1280x720 and applied this. Finally a proper picture! :smiley: Then a message appeared saying that I am not using an optimal resolution for the display. What?? :confused: I just closed the message box.

Next, I tried switching to the external display only so that my laptop display would switch off with the projector running. When I did this, the screen on both displays went blank. :doh: After waiting ~20 seconds, I decided to press the Fn-combination to switch back and noticed that it changed the resolution back to 1280x768. When I was about to try again, I noticed some text saying that when switching to a single display, the resolution cannot be set until I apply this setting first, as Windows needs to first set an “optimal” resolution before it can be manually set. Obviously Windows 8 is not choosing something my projector supports and unfortunately without the ability to see the picture in external-display only mode, I can’t change manually change it to 1280x720. The only workaround I could find was change to clone-display mode, set the resolution to 1280x720 and turn the laptop display brightness as low as possible.

Now with the resolution sorted, I double-clicked the title to start playback and …

The title I tried playing is 1280 x 720 and my display resolution is also 1280 x 720. How can the resolution be too low, Windows 8? :rolleyes:

I then tried a standard resolution title, but go the same message. It turns out that the Windows 8 Video App does not support a vertical resolution under 768, e.g. 1280 x 768, which is probably why it kept trying to set my display output at this. For the computer illiterate, this message makes it appear that video cannot be played at all with this resolution. :confused:

For curiosity, I tried opening it with Windows Media Player and surprise-surprise it plays just fine. The Windows 8 Start screen also appears to work fine in 1280 x 720, but I haven’t tried other Apps, at least not yet.

So for anyone having trouble using a 720p native TV or projector, this is my workaround:

[ol]
[li]Press the Windows Key + P repetitively to select “Duplicate”.
[/li][li]Right-click the Desktop and click ‘Screen Resolution’.
[/li][li]Click ‘Advanced Settings’ and click ‘List All Modes’
[/li][li]Pick the proper resolution to use, True Color (32 bit) and matching Hertz (50Hz for PAL and 60Hz for NTSC)
[/li][li]Click ‘OK’ to both boxes. Now your TV or projector should show a sharp picture.
[/li][li]Close off the message about non-optimal resolution use.
[/li][li]Right-click on the title you’d like to play and select ‘Choose default program…’
[/li][li]Click your favourite player. Don’t choose ‘Keep using Video’ as that’ll not work. :disagree:
[/li][/ol]

With Windows 7 I just plug the projector in and click play.