Windows 7 + RPC1 drive = No playback for copy protected DVDs

vbimport

#1

Hi Everyone,

I’m not sure if this was brought up by anyone recently but I just resolved a long standing issue I’ve encountered when I built my Windows 7 HTPC.

Since the beta until RTM (from my MSDN account) my commercial DVDs with copy protection just wouldn’t playback. The most I would get is either the intro video or the copyright warning. Once it reaches the menu or I start the main video, it would just result in an error in either Windows Media Player or Windows Media Center. The error message would point to either a driver issue (chipset, drive controller, video adapter, etc) or an incompatible device. Checking the system event logs, it also lists cdrom based errors.

I tried checking everything from my codecs, my HDMI cable, my generic TV, installed official/unofficial drivers, re-installed windows (32 and 64-bit versions, beta, rc, RTM) but no go. VLC worked fine but I wanted to keep things as native as possible since I’m using an HTPC remote meant for Media Center/WMP.

I noticed that my laptop with a bluray burner worked fine and the only difference I noticed was that the DVD properties in device manger had a region tab and that I’ve never tweaked/updated the firmware. So I reflashed my RPC1 Samsung SH-S203B on my HTPC with the official firmware and surely enough the tab appeared on my HTPC and no more playback problems. I then re-flashed it with all tweaks minus the RPC1 with the Codeguys tools and still no problem.

I checked my other Windows 7 builds with Pioneer, Lite-On, BenQ RPC1 firmware and it was the same thing. No playback until I re-flashed without RPC1 enabled. I haven’t checked if this was an issue in Vista and XP but last time I used these OS’s I don’t recall any problems with commercial DVDs when I had RPC1 firmware.

I know that you lose the region-free aspect of the drive but I’ve honestly only had two Region 2 discs that RPC1 firmware helped out with which I haven’t watched in years. I might as well just rip them and make them region free. Hopefully this helps out anyone else having problems.


#2

So this is a feature of Windows Media player since other players do work. The evil thing are the misleading error messages. :rolleyes:

Michael


#3

If you have one of the latest Optiarc drives, you might try an auto-reset firmware from my site. The drive pretends to be RPC2 but resets the region counter each time you insert a new disc.


#4

[QUOTE=Liggy;2452836]If you have one of the latest Optiarc drives, you might try an auto-reset firmware from my site. [/QUOTE]Autoreset firmwares are also available for some LG drives (Patching with MCSE required). :slight_smile:

Michael