Windows 10 Creator update


#1

Anyone else have an issue with this update? Download went ok, but my computer locked up at 23% and was stuck. Absolutely, irretrievably stuck, with odd artifacts on the screen where the little circle of twirling dots was supposed to show that the update was still being processed.

Downloading again now.


#2

How does one know they got this update? I update last night but I did so from a clean image and saved the image update.


#3

It worked the second time.

And you’ll know when it does work. It starts you off in the Edge browser, with buttons to click to see what is new.

Oh, it also put the Mail icon on my toolbar at the bottom of the screen, which I immediately deleted. Had to go through and change some of the privacy settings too. They added some extras.


#4

Goto settings/system/about and it will display the version and build numbers.


#5

You can also go to - settings, system, about - where it will show the new OS build number, which should be 15063.13 fro the Creator Update.


#6

I installed it on 10 computers so far (some at my workplace) and the actual update process completed successfully on every computer.

My ageing home desktop PC was the only one so far that gave trouble, which turned out to be a problem with Malwarebytes3 Premium. I ended up reverting to Malwarebytes2. Version 3 had various issues such as prevent Word and Excel working properly, throwing up pop-ups that some component is disabled and even causing noticeable stuttering (reminds me of McAfee).

One other issue I noticed with the Creators Update is that takes a lot longer to boot on both my home and workplace PCs. With Fastboot disabled (or a full restart), it displays a black screen with a spinning circle for about 1 minute before showing the login screen.

My workplace PC also lost sound after the update. Microsoft replaced the soundcard driver with its own driver during the update and it would not let me roll it back. However, this was easily fixed - I downloaded and reinstalled the soundcard driver from HP for this PC and the sound returned.

So far I haven’t heard any issue with the other PCs and laptops that were updated. Besides the longer boot time on my PCs, I haven’t had any further issue either.


#7

I also did installed the creators update using the tool that microsoft provides and so far everything appears to be fine, even the host file appears to be untouched.


#8

By the way, O&O Shutup 10 has a new version, specifically for the Creator edition.


#9

Wonder what Microsoft found that they change to bypass O&O shupt10???


#10

I don’t think MS did anything to affect O&O Shutup 10 adversely. They just added some privacy features in Win 10 that required a new version of that program.


#11

That means MS isn’t sitting back then.


#12

Nope mine is

Version 1607
OS Build 14393.1066


#13

You have the Anniversary Edition not the Creators Edition


#14

Guess I am not creative enough…:joy:


#15

2 desktops and a laptop so far with no issues. I went through the link on my Windows update page and upgrade now after installing Windows 10 Upgrade Assistant. Also got the latest DoNotSpy10 on all 3 to shut some more stuff off.


#16

Like I wrote elsewhere, 1703 is by far the most ‘smooth sailing’ I’ve had upgrading whatever installation Win10-Win10 (and one 7-10 likewise worked perfect)

A few general hints though…

  1. Uninstall any and all 3rd-party antivirus and other security minded real-time scanners and reboot before you begin… you don’t want them installed and running (stopping them may not be enough)!
  2. Download the upgrade and burn media/transfer to USB. This time I’ve mostly heard about freezing troubles from people doing online upgrades.
  3. Don’t rush it! On older installs, some steps seem to take a while… Worst so far is about 45 minutes for the middle phase (no hang, just a tad old hardware that’s all)… In other words, take a walk or do whatever else and wait (especially frustrating on laptops without any storage activity led) :wink:

It behaves flawless on all but one install, but considering my hobby computer to be anything nearing normal would be a stretch and so it is to be expected. The fun now is that it does not happen too often and lasts for only a short time… so I have not been able to figure out what it is (I’m getting there)… The trouble? Let me show you a screenshot:

Now this here folder is usually sorted by ‘Details’ and did show only generic icons and as you can see, the ‘View’ tab has all view modes greyed out. Right-Click works though and that’s what I did prior to taking the screenshot notice how there’s no icons at all after changing to medium or large icons (not sure what I did choose), not even the left navigation pane show anything, no quick access a.s.o. 10-15 seconds later everything is O.K. again only to appear again from hours to a day later, this time affecting another folder. What puzzles me is that I can open other folders while this occurs and they display fine (‘Launch folder windows in a separate process’ active)… All I know is that it’s related to explorer, but why not all? :laughing: