WIN XP, VIA and UDMA

vbimport

#1

Just thought I would post my latest experiance. I used to have the following config:

IBM Deskstar 40GB Primary Master UDMA 5
Fuji 6GB Primary Slave UDMA 4
Creative CD-RW 12x10x32x Secondary Master PIO
Relysis DVD 16x Secondary Slave UDMA 4

I went out and brought a Liteon 40x12x48x added it to this config

IBM Deskstar 40GB Primary Master UDMA 5
Fuji 6GB Primary Slave UDMA 4
Liteon 40x12x48x Secondary Master UDMA 2
Relysis DVD 16x Secondary Slave UDMA 4

Win xp would boot and lock my HDD into PIO mode, no matter what config I used both drivers and aranging hardware on different cables the HDD would stay in PIO mode even after a format.

I then tried installing winxp only using my IBM HDD and my CD-RW. HDD was in UDMA 5 and CD-RW was in UDMA 2. Next add DVD that in UDMA 4, now add fuji drive, BANG both HDD back into PIO mode. I then tried it again but added the HDD first that went in as UDMA 4 added DVD and back to PIO.

I have a VIA IDE controller on my mobo and it seems it cant handle more than 4 UDMA devices without win xp thinking UDMA is having a problem and locking the drives in PIO mode.

Beany


#2

This works on Win Xp
look for this key

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002]
“EnumPropPages32”=“storprop.dll,IdePropPageProvider”
“InfPath”=“mshdc.inf”
“InfSection”=“atapi_Inst_secondary”
“ProviderName”=“Microsoft”
“DriverDateData”=hex:00,80,62,c5,c0,01,c1,01
“DriverDate”=“7-1-2001”
“DriverVersion”=“5.1.2600.0”
“MatchingDeviceId”=“secondary_ide_channel”
“DriverDesc”=“Secondary IDE Channel”
“MasterDeviceType”=dword:00000001
“SlaveDeviceType”=dword:00000002
“MasterDeviceTimingMode”=dword:00010010
“MasterDeviceTimingModeAllowed”=dword:ffffffff
“MasterIdDataCheckSum”=dword:00019e33
“SlaveDeviceTimingMode”=dword:00002010
“SlaveDeviceTimingModeAllowed”=dword:ffffffff
“UserSlaveDeviceTimingModeAllowed”=dword:ffffffff
“SlaveIdDataCheckSum”=dword:000129b9

This is for the secondary IDE channel on VIA systems. I had a problem where a Creative 52Xmx was recognized as PIO. It was set at secondary slave.

The main keys here are:
“MasterIdDataCheckSum”=dword:00019e33
“SlaveIdDataCheckSum”=dword:000129b9

Again for IDE2. Make sure where is it located and DELETE the apopiate key then reboot. The system will recognize it again. That’s how I fixed my problem and it works like a charm.

If it is for IDE1 look for this key (search in regedit):
“MatchingDeviceId”=“Primary_ide_channel”


#3

Its not a problem with the devices being recognised properly. Win XP detects a “problem” on my primary IDE channel as it seems the IDE controller cant function properly with 4 UDMA devices. When it detects this it goes and locks my HDD in PIO mode as it thinks there is a UDMA problem. Only solution I found is to only have 3 UDMA devices on my mobos IDE controller. If I reg hack it will change them but they do not run it that mode (benchmarked them before a reboot) and win xp will not reboot


#4

The registry hack does work…I did it myself.

However, what you are mentioning looks more like a hardware problem. Does this happen with XP’s default controller drivers and latest VIA’s?
If the answer is yes and you are on a budget I recommend you to get a ATA 100 controller.

Hope this helps.