Win XP 64 suddenly can't see either PATA DVD drive

vbimport

#1

I used to be able to burn DVDs with good test results. Then I suddenly couldn’t get a usable burn for anything. I spent some serious time studying CD/DVD speed and tried to burn a test disk - it failed to complete. After reading many posts on the forums, I checked the Device Manager and noticed the drivers were still there for a PATA insert card that I had removed (I lost a 120 Gig PATA HD.), so removed it. I also noticed there were 3 sets of Primary and Secondary IDE channel items. I have Win XP 64, so maybe 1 of them is 32 bit and the other for 64 bit. I don’t know.

After rebooting, there were only 2 sets of Primary and Secondary IDE channel items. I checked the DMA settings and one was on PIO transfer, so changed it to DMA. Don’t know which drive it affected. After all this, Win XP 64 would NOT/could NOT see the drives. I have a NEC 3550A (1.06) and I think a LiteON, but can’t remember and don’t want to reboot at this point. (CMOS recognizes both drives)

The only real solution I found that seemed reasonable was the one to remove “Upper filter and Lower filter” in the registry. Trouble is, there were 24 entries with the same name and only about 2 had an “Upper filter” in it. No “Lower filter”. I deleted the 2 entrees as MS instructed and on reboot, lost all external control of the system - both mouse and keyboard - even in safe mode. My only option was to revert to “Previous good registry”. Since then, I have found little else help.

I see here and there to remove the IDE entries and let Windows rebuild them. But they always refer to only 1 entry each of primary and secondary. So I’m very hesitant to do this.

It seems there aren’t many Win XP 64 units left out there, so not many answers. If anyone can help me, I’d truly be grateful.

If push comes to shove, I suppose I could buy a new SATA burner, but these drives have served me well in the past.

MB - Gigabyte X48-DQ6
Ram - 4 Gig
HDs - Primary - 500 Gig SeaGate
- 1.5 Tb
- 2 Tb


#2

I’d say, get your self a good SATA Blu-ray Burner, set it up properly and use IMGBurn and Verbatim Media. You don’t have to keep tweaking and testing if the Drive is set up properly. :cool:


#3

I’m just curious, when you installed Windows, did you have to provide drivers for your hard drives to be recognized? If not, you can likely safely remove all entries for primary and secondary channels and have Windows not utterly fail.

If you DID have to provide drivers for Windows to detect your hard drive for installation, then in Device managed, you can change the view to something along the lines of “view devices by connection”. It may take some hunting, but if done, you can see what ports your hard drives are running off of, and safely delete any OTHER entries in hopes of letting Windows recognize the optical drives again.

It is also possible you have to reinstall Windows from scratch, or at the very least “repair” it using the installation media.


#4

[QUOTE=Albert;2643856]I’m just curious, when you installed Windows, did you have to provide drivers for your hard drives to be recognized? If not, you can likely safely remove all entries for primary and secondary channels and have Windows not utterly fail…[/QUOTE]

No. They were all OEM and Windows found them just fine.
I got brave and stripped all 4 IDE channels and let windows rebuild them. However, on reboot, it “found” each drive and demanded a reboot, upon which, CHKDSK started on one drive (2nd partition on 2nd drive) before loading windows. It found a single file and index error and corrected them. After finishing, it would hang as though expecting some input, but the keyboard was not active. After a hard reboot, it started up and there were no DVD drives and the IDE channels were both restored (2 primary and 2 secondary channels).

In case there was a problem with the 2nd DVD burner, I removed it and on reboot, got the same CHKDSK routine on the same drive partition - different errors, but deleted them. I’ve never before experienced the CHKDSK not passing on control to the boot process of Windows when finished. Still no access to the single DVD burner.

I will try to install it into another system and see if it works there.

[QUOTE=Albert;2643856]It is also possible you have to reinstall Windows from scratch, or at the very least “repair” it using the installation media…[/QUOTE]

That would be an ungodly amount of work and am not prepared yet to do that. Besides having an intense dislike for Win 7, the main reason for not upgrading is that I have many expensive programs that will not migrate.
Thanks for the suggestions.


#6

Well, I put the NEC 3550A in another Win XP system and it was imediately recognized in windows. I didn’t do any burning in that system, but the fact that it seemed to function normally, indicated to me that it is MY system that is at fault. So I put it back into my gigabyte machine but connected it to the PCI card instead of the MB. Windows now sees the drive and it works “OK”, but still can’t get a decent DVD burn. Will have to pursue some different discs. I thought they were Tayo Yuden.

If anyone is able to explain some of the strange registry entries I noted in the earlier posts, I’d love to hear from you.


#7

We too have had XP64 customers in the past 6 months who ‘lost’ IDE drives and we replaced those, and those units worked fine. We wrote those off to “eventually all devices die”. But yours is the second case I’ve heard that Win Reg seemed to offer problems and IDE replacements didn’t work. Our folks haven’t heard of this happening (now they’re all anxious about it!)

On other of our XP64’s, we have replaced some IDE burners with SATA drives because those PCs had SATA ports available. That wasn’t to solve any problem - it was to swipe IDE drives and store those for eventual use if need be, and to see if merely dropping in a SATA would work. Yes. Great. Cheap. Widely available too.


#8

these may help you to recover a corrupt registry

http://www.aade.com/XPhint/XPrecovery.htm


#9

[QUOTE=macnavarra;2644685]these may help you to recover a corrupt registry

http://www.aade.com/XPhint/XPrecovery.htm[/QUOTE]

Thanks. Great keeper doc. When things get desperate, it’s sometimes hard to think clearly.

I just had a thought - I noticed that there are 2 Regedit lines saved under “Run”. One is just Regedit and the other is Regedit32. Are they the same thing, or is their actually a different access to the 32 and 64 bit aspects of the registry? My instincts are that their is only one registry.


#10

there is just one registry. The Regedit.exe is native 64 bit. The regedit32.exe runs on the 32bit WOW layer of the 64bit Operating System.


#11

I have good luck in Device Manager to uninstall device, let it rediscover and the reinstall MB driver over top.

But SATA is good option to buy if you have support in hardware for it.


#12

What is odd that I have observed is that some computers are temporarily forgiving of master/slave/Cable-select jumpering.

I had one system running for 2-1/2 years that was very happy… until one fine morning it wouldn’t start…

No boot device found. I thought Oh sh!t! the HDD failed…

Nope. the clue was that neither drive on the primary IDE channel was seen and sure enough when I pulled the drives both the “master” and the “Slave” were jumpered master. The computer accepted that configuiration for >30months until one day it didn’t.

another system here just did the same thing after six months, the replacement boot drive had been installed without changing it’s jumpering from slave after a cloning operation from a drive that SMART said was in danger, it ran with both drives on the primary channel jumpered “Slave” until a momentary power glitch after which it wouldn’t restart.


#13

That’s a great observation Allan. However, I had double checked that factor.
Subzero, I was frustrated that the device manager never did see the drive - Unil I re-introduced the PCI card as stated earlier.
Thanks all


#14

I just built a system for a friend (3570k) and he’s still using 2 samsung dvd burners… making them install drives is a PITA because you need to insert drivers first… so I brought along my sata burner for the install. Everything seems ok… although I was a bit uneducated about how to setup a 3tb hard drive so he has partitions… doh!

Anywho, I have an old nec 3500a drive that started giving me burn problems… and I think the laser started going… well over 600 burns on that drive–plus a whole lot of readback hours… this is in my secondary old system that I keep around as a backup. I doubt this is a driver problem… the pie/pifs keep showing a consistent error spike (like a skipping record that is not looped) that is specific to this drive… maybe the tracking arm is caked with dirt and it bumps/jitters around there, or the laser is beyond it’s useful lifespan?!? I dunno, I’m beyond caring at this point… I have a lg 10x blu ray burner & a samsung lightscribe dvd burner in the new system.

Can’t recommend ide drives for new (non backup systems)… stop being cheap & buy a sata dvd burner at the minimum ($20)-- blu ray if you can afford it ($60). It’s quite possible you could strike gold & pull a sata burner out of a curbside PC being thrown out… for free. Most smart people will pull the HDD for data security but rom drives are usually intact (and working). Just as long as it doesn’t look like it’s been in a flood you can probably trust it in your PC.


#15

That’s weird