Wifi connection not working. HELP!

vbimport

#1

I was trying to connect my laptop to my computer where I have DSL cable internet which I’d like to share for my laptop. Since I’m bit lacking money currently, I’ve decided to go for a wifi adapter for the pc since the laptop already has a built in card.

/Laptop: Atheros AR5007eg, PC: TP-Link TL-WN322G USB 2.0 adapter 54mb/

I’ve tried to create a ad-hoc connection but failed. Eventually I’ve figured not to let Windows configure the connection so now I have TP-Links utility managing it on the PC and Toshiba Atheros Client Utility on the laptop /eventhough it’s an acer but it did not come with a software, seems to work though I might be wrong/.

I’ve set up a ad-hoc connection /on the pc it sas: Station :confused:/ on channel 1, WirelessMode: 2.4GHz, I’ve set SSID, Networktype:Ad hoc, Authentication:Shared key, Encryption:WEP /I’ve set a 13 character key/.

I’ve tried to set the same things on the laptop so SSID same, channel same, Pre-Shared key /same as on pc/ for security options, WirelessMode 2,4Ghz /54mb/ and 2,4Ghz /11mb/ both checked, Type: Ad-hoc, 802.11b portable: Long only /tried Short-Long too/, Wireless mode when Starting up: 2,4gh /11mb/ /tried 54mb option too/.

Result, laptop and PC sas connected, signal excelent. Can ping laptop but cannot ping PC. Connection not firewalled. Internet shared /not like it would work/.

Tried Access point mode on PC, added MAC address of laptop. It appeared on the list on the PC’s utility. Changed laptop setting from Ad-hoc to infrastructure. Can ping laptop, cannot ping PC /request timed out/ but shows “Connected”.

What am I doing wrong? This is the first time I’m trying to create a wireless connection, but I really want to make this work. Ideas?


#2

Maybe this will help: Link

Also make sure you have the latest driver/firmware for both computer wireless devices.


#3

Thanks for answering and for the link!

I’ve tried to go trough the guide you gave, but half way on it I’ve lost a tab :eek:. Now I do not have a “Wireless Networks” tab next to my “Advanced” tab under the connection’s properties /but still have it on the laptop which is weird since I’ve used the same cd for the Windows install/. Still somehow it managed to connect and I could ping the laptop IF the laptop was being managed by Windows too. Sadly it didn’t solve the pc pinging since that’s still “Request timed out”. Since I cannot change setting based on the guide I’ve went back to the wireless utility /atleast until I manage to figure out how to get back that tab :confused:/.

I’ve updated the driver for the adapter on the pc and thanks to that now it doesn’t matter if it’s the utility or Windows what manages the connection on the laptop I can ping the laptop but still cannot ping the pc /didn’t update the laptop since I always use the newest from the company website 'cause the resource cd is damaged and won’t isntall the driver, also I’ve installed it today from the net/.:sad:


#4

If its still possible to return the wifi card, you could do that and buy an inexpensive wireless router. That would allow you to share to internet connection without the need to leave the main pc on.

8 bucks + shipping after rebate


#5

See http://www.buy.com/retail/usersearchresults.asp?querytype=home&qu=TRENDnet+TEW-432BRP&qxt=home&display=col&dclksa=1
where same router is $10 after rebate with free shipping. I’ve used one of these routers for about 6 months now, and it has excellent range and have had zero problems.


#6

Thank you for both of you! I’ve took back the adapter today but they could not return my money so they’ve told me I could buy a router there /now I have a TP-Link Wireless Router, it turn out quite cheap/ and now I’m writing from my laptop through the shared internet connection!:flower:

Thanx for your help!