Wierd VOB to DivX issue

vbimport

#1

I’m not sure where to post this mods, so move it if you need to.

Ok, with that said, I’m having a strange issue backing up one of my movies, ‘the fifth element’. It’s strange in that I have no problems ripping the DVD to VOB format (using DVD Decrypter 4.0, FAB, and a variety of others), and watching the VOB in windows media player, the DivX Player, or PowerDVD, however when I try to use Dr. DivX to encode the VOB to DivX, It gives this error message:

‘Cannot find a video stream in the file VTS_01_1.vob’. The file you have chosen may not have a video track.’

I’ve tried several ways of ripping the DVD, including converting it in DVDShrink to a single VOB, but nothing allows it to be read by either VirtualDub or Dr. DivX. It’s really starting to be annoying, in that I can watch the VOB perfectly, but can’t encode. Has anyone run into this problem before, and what can I do about it?


#2

Sometime the movie is not on the first vob file; many times on a DVD there are many VTS_ files; try to choose another file (generally the main movie is on the longest sequence of vob files). Maybe the vob files selected, and giving this error, contain a menu instead of the main movie.

Hope this can help


#3

I’ve tried that, and yes that is/was part of the problem, but I removed that vob in Shrink. The main problem is still recurring. Dr checks all the vob files, and says that none of them contain any video streams. This problem is pretty frustrating, in that I can encode just about anything else easily, but for whatever reason this DVD is being difficult

I think I posted this in the wrong forum. If a mod wants to, they can delete this post.


#4

Please explain better. When you rip the movie on hard disc do you modify it in any way? Or you rip the entire disc?

I’ve noted that sometime ripping only main movie with DVD shrink give problems during avi conversion; I don’t know if is a bug of shrink or not. What exactly did you used to rip problematic movie?


#5

I’ve used DVDDecrypter 4.0. I’ve tried ripping the entire DVD and ripping only the main movie files and IFOs. It seems to rip fine, no problems, completes just as it should. The movie plays fine in VOB format on windows media player, the player, PowerDVD, etc.

I try to open it in Dr. Divx and it gives me the aforementioned error. VirtualDub also, cannot open the VOB file. I’ve only tried using shrink to get the Dr to read the file. So far, nothing has worked.


#6

I suggest to rip ALL disc, because I had also issues in converting in avi when rip only main movie. I don’t know exactly why, but if rip entire disc haven’t problems, whereas ripping only main movie I’m not able to encode in avi.

:cop: Another thing: please don’t crosspost. Is against forum rules, but above of all can generate confusion between forum users.


#7

ok sorry geno. I’ve tried that (ripping the entire DVD) and it hasn’t worked, but I’ll try it again.


#8

Maybe I can give you another suggestion. Usually I don’t use dr.divx.

Sometime ago I tried it an found it really buggy and not user-friendly.
Try to use another application.

Many uses Gordian Knot (free and opensource), but this is a bit complicated: many parameters to set (for advanced users).

Another apps is XMPEG, also freeware and very simple to use. Give a try to these apps