Why is my Sony DRU-820A so slow? (1h30m @ 16x!)

vbimport

#1

Hi guys,

I posted in the Newbie Forum yesterday with this problem and another question, but I think I need to post here now about my DRU-820A slowness. :sad:

I recently got the drive (first DVD burner :o) and had just burned some CD-RWs and DVD-RWs, and now am wanting to do +Rs. The 2x DVD-RWs worked as I expected, taking 30m. My +Rs are 100 Fujifilm 16x, which are identified as PRODISC R05. Of course I left the first one set to 16x in Nero (6.6.0.18) and it took an hour and a half! The second, and last, I set to 8x speed and it “only” took 48 minutes. Also, for both burns the Buffer Level dropped below 50% every 1-2 seconds (Nero’s Read Buffer is always at 100), is that supposed to happen? It never goes lower than 95% with the DVD-RWs or CDs…

It was on an ATA-33 connection, since I was using a 40-wire cable, and I figured that 33MB/s should be enough for 16x; although I’m not sure if it runs at the full speed with my VIA Apollo Pro133A chipset.

I was wondering if it needs to be ATA-66, so I found an 80-wire cable to use instead. Now the BIOS warning is gone about “using a 40-wire cable” and the BIOS screen says it’s in ATA-66 mode. In Windows, Device Manager still just says “Ultra DMA Mode” as before – I don’t know if it’s supposed to differentiate between DMA modes or not…

I haven’t tried burning another +R, but I checked my ripping speeds again and CD-DVD Speed benchmark, and it’s no better than before. Using the DRU-820A OR my 6 year old Pioneer 16x reader (ATA-33), DVD Decrypter only shows ~3.5x speed. Similarly, in CD-DVD Speed, reads are only 6-7x max (actually, I think the old Pioneer performs better in the few comparisons I’ve done), whether using -RW, the +Rs I made, or a pressed DL. Shouldn’t I be getting speeds around 16x like I see in the CD Freaks reviews? (I know not all types will be that fast.) BTW, for the Interface Burst Rate, it only shows 10/17MB for the Sony/Pioneer. :eek: That doesn’t seem right?

I just don’t understand what’s going on. :frowning: Why are my burns/rips/reads so far off of what they should be? PLEASE help me get it working right. :bow: Here’s my system details so you hopefully aren’t wondering. :slight_smile:

Windows 2000
Dual 930MHz PIIIs
576MB
2 Hitachi T7K250 drives (8MB, 60+MB/s) on Promise ATA-100 controller
Sony burner, like Pioneer reader, on its own channel on VIA IDE controller

Thanks in advance for any help!


#2

Hi,

that sounds, if DMA mode were off for your drives. Please check with Nero Info Tool.

Also, you should have

  • VIA 4in1 4.43 (not the more recent Hyperion) drivers installed
  • VIA IDE busmaster driver not installed (the drivers provided with Windows are more reliable)

Michael


#3

The VIA Apollo KT133A chipset is known for problems. You might have a change to enable DMA without getting a BSOD if the drive is connected to the primary IDE controller. Run cdspeed’s burst rate test, it should display > 20 MB/sec.


#4

Didn’t reply sooner since I’ve been trying to figure stuff out, changing things, etc. :eek: BTW ala42, I don’t have a KT133A chipset :slight_smile: (isn’t that an AMD one…? dunno), but yeah, the VIA IDE performance is poor.

I had the 4-in-1 4.43 drivers (including IDE) installed. I found before I got the burner that using the Microsoft IDE driver makes audio CDs stutter at the beginning when played in the Pioneer reader. I tried switching back to the MS one again, and it only barely improved the Sony’s read/burst rate (10-13MB instead of 8-9MB). CD-DVD speed showed that it hits a “wall” around 9x and both lines are up and down a lot… (I saved the results if anyone wanted to see them for any reason.)

Then I decided to try moving the burner onto the cable with a hard drive, on the mobo’s onboard Promise ATA-100 controller. Then the burst rates were ~38MB/s and +R or pressed single-layer reads were @ 16x! I then tried to burn again at 16x speed, with the source files on the hard drive sharing the Promise IDE channel with the Sony – still took 1h10m! (The Buffer Level didn’t drop as low as often as before.) I figured it might be because of the channel sharing, so I tried another with the files on the other physical drive/other channel and didn’t even use the system while it was burning. Nope, it actually took 1h15m. :rolleyes: Well there must be too much happening for the Promise controller to handle, even on separate channels.

I figured I might as well move it back to the VIA IDE (using VIA driver again), and just use 4x speed (more on what else made me try 4x in a sec). THAT completed in 15m, which is fast enough for me, really. What I still don’t understand is, why didn’t I see ANY difference in read/burst speeds when I switched from the 40-wire to 80-wire cable (and the BIOS now says ATA-66 instead of ATA-33)?! I tried uninstalling the burner and its IDE channel, so it would be redetected, and anything else I could think of. I haven’t tried another 8x/16x burn since being back on the VIA IDE, but I assume it’d be the same since the benchmark is the same – pathetic. Does Windows 2000 not want to run optical drives in UDMA Mode 4? Is there any tool to check the actual Ultra DMA Mode since Dev. Manager doesn’t specify? (I checked by benchmarking a hard drive in ATA-66 on the VIA IDE.)

Another problem: Now the recorded +Rs won’t load/play 95% of the time on my standalone Pioneer recorder!! :a It’s a DVR-510H (with DVR-106X drive it looks like) and it loaded/played those first 2 discs I made (put them in 4-5 times total). Now it just ejects them, except it seems more likely to occasionally load the one burned at 8x, so I thought they were done too fast, which is why I tried 4x. But, no difference. I don’t think I got it to load once. Another unit (DVR-310), which I guess is the same DVD-wise, just without a hard drive, has loaded & played any of them every time I tried (over 30 times probably).

Any ideas about that? Could the lens be dirty, only affecting +Rs? (Don’t have any -Rs.) Could the drive be taken out and the DVR-106 firmware updated on the computer? Replace the drive? (I guess I should post in the standalone DVD recorder forum.) Totally sucks… I’ve gotten everything else figured out to make DVDs how I want them (even if I have to burn at 4x! :D) and the recorder when I want to play them decides to quit reading the discs! :sad: Everything else, pressed discs, and the same content burned to a -RW works fine BTW.

Finally, I saw that Nero Recode only had the target size at 4459MB, so I increased it to 4482MB. Why is the default 20MB+ less than disc capacity? I’m not hurting playback by putting “too much” on a disc, am I?

Thanks for any more help! :slight_smile: My main concern now is playback on the standalone Pioneer, but also curious why ATA-66 didn’t help the burner.


#5

Perhaps booktyping(bitsetting) to DVD-ROM might help compatibility. Nero can do that at burn time or maybe it can be permanently set by CD-DVD Speed or DVD Info.


#6

Sorry, forgot to mention that I have set them all to DVD-ROM booktype :slight_smile: (verified after with CD-DVD Speed) – I set it in Burning ROM (since I didn’t know what “Automatic” would create) and in CD-DVD Speed (does that change the default inside the drive?).

I just bought the 100-pack of +Rs for the Sony, since I only record RWs in the standalone Pioneer (a “-” format recorder only). I knew that the +Rs have higher compatibility since you can change the booktype (if the burner lets you), but since I’m only dealing with “-” format standalones now, I’m wondering if using -Rs would’ve worked better. :doh:


#7

I was having the same problem, and I didn’t really know it until I used someone elses burner, and wow, it was only 45 minutes for a straight copy, including the image to the computer! It was a 12x HP DVD burner… which prompted me to look up the problem-lo, here I am.
This article inspired me to fix it, and I did! Thanks to some of your buzz words, guys, and digging up the manual…
You were right… the Nero Info tool did say that the DMA was turned off (it never was on in my case)… I went into Device Manager, and went into the IDE/ATA ATAPI controllers list, and double clicked the primary IDE channel… clicked the Advanced Settings tab, and in the transfer mode for the device number (I did change mine to a MASTER on device 0), and changed the setting to DMA, if available-built in not to create a conflict, I guess.
I also, am running Windows 2000… I went into the settings mode during the boot up… and there are several options there that need to be tweaked, too. One was to let the drives running fastest (but noisy, it said). Another one I changed-I can’t even remember what it was, but it “made sense” to this problem.
Wow! Now, a straight copy, including the image to the computer took a total of 16 minutes… a full capacity disk!
The manufacturer’s instructions does say that it needs to be DMA capable… but falls short of saying to turn the DMA, if available, option on (which was detailed earlier, in Device Manager).
I saw the 18x’s being sold recently, and thought about buying one of those to get the speed I want… but now, I don’t need it. 16 minutes is burned up so easily… I don’t see how much faster it has to be.
I hope this note helped you…
from another owner of the Sony DRU-820A “16X” burner…