Why is my Plextor PX-760A so slow at writing DVDs?

Four months ago I bought a new Plextor PX-760A for my Dell 670 Precision Workstation. Until yesterday, I had only ever used this drive to read DVDs. I am now trying to use it to make data backups using Roxio Easy Media Creator 8 (downloaded yesterday) and Verbatim 4X DVD-R discs. However, I am having major problems.

Instead of writing at 4x it is writing at about 0.4x, ten times slower than expected! My Windows XP PC is also having other problems after starting such a backup. Other programs hang up until the backup is completed (after over 3 hours!) and then the PC will not close down properly. After a forced power off and reboot the PC once again behaves perfectly - until I start another backup. Despite all these problems, the backups are actually okay.

Following guidance on the Roxio website, I have taken the following action.
(1) Installed the latest firmware (1.04) for the PX-760A
(2) Set my PC to operate in DMA mode
(3) Uninstalled the PX-760A in order to force a reinstall of the driver

However, none of these actions made any difference. I then installed the trial version of PlexTools Professional XL that came with my drive and ran a DVD write diagnostic test. This produced exactly the same result as with the Roxio software, i.e. the write speed was only about 0.4x. It therefore appears to be a Plextor or Win XP problem, not a Roxio problem.

Any suggestions on how to make my DVD-RW drive run properly?

Didn’t we read the forum rules about double posting (aka cross-posting)?

I’ve posted against your other thread & will report this so it’ll be closed & not cause further confusion.

You have to reinstall the complete channel. I’ve come across this with my 716. Deleting the drive alone does not switch back to dma. You need to do so with the channel (e.g. secondary ide channel).

Tim,
My original mistake was to post my question in the general hardware forum before realising that there was a more specific forum for this topic. I then copied my question here and edited the original post to delete the question. I guess you must have read it during the couple of minutes it survived as a double post!

How do you delete a channel? Please provide more details.

Tim,
Thanks for your reply to my short-lived post in the general hardware forum. For convenience, let me repeat it here,

"This is typically because of several possible reasons.

  1. DMA is not properly enabled. The Current Transfer Mode for an HDD should be Ultra DMA mode 5 or 6 and for an optical Ultra DMA mode 2 or 4.

2 Severely fragmented HDD allied to low free space. Defragging should be done on a regular basis.

  1. Suspect IDE cables. Good quality 80wire (aka Ultra 66/100/133) cables are essential.

  2. The burner on the same IDE channel/cable as the HDD.

  3. Crap media"

===============================================

My comments are,
(1) The Win XP Device Manager tells me that both Device 0 and Device 1 of the Secondary IDE Channel have a Transfer mode of ‘DMA if available’. The current transfer mode of Device 0 is Ultra DMA Mode 2, while the current transfer mode of Device 1 is ‘PIO Mode’. I’m guessing that my Plextor is attached as Device 0. This suggests that DMA is properly set.
(2) The source location for the files being backed up is a 300GB SCSI disk with 93GB free space. I haven’t checked fragmentation status yet but would be surprised if it were to be a significant issue.
(3) The IDE cable came supplied with my Dell 670 and is presumably of acceptable quality.
(4) All my hard disks are SCSI, so no competition with my IDE Plextor.
(5) Verbatim appear to be a respected supplier of media and a PlexTools media test ran okay.

Does this all sound ok to you? If yes, any more suggestions?

Select the correct channel (the image is just an example) and press “Delete”. Confirm the dialogue.

On XP, the channel should be detected immediately. Reboot if necessary.


What’s the other device on the IDE channel that’s running in PIO mode? You should know as I’m assuming that you installed this new drive.

I’ve got a feeling from a review of this drive I’ve read that it should run in Ultra DMA mode 4 not 2. If this is the case then it must use 80wire cables & I wouldn’t assume anything about what Dell might supply.

If you’ve got Verbatim 4x media these must be quite old & might not be too well supported by a modern hi-speed drive.

Tim,
The other device is an ordinary CD-ROM drive that was already on the PC before I added the Plextor. According to the device info from PlexTools, the PX-760A can run in PIO Mode 0-4, MultiWord DMA Mode 0-2 and Ultra DMA Mode 0-4. Even if I’m not running in the slickest mode possible it should surely never drop down to 0.4x speed?

Prompted by your comment about the age of my 4x discs, I have just started to run another Roxio backup job using a Verbatim 16x DVD-R disc that is only a few months old. The backup job defaulted to a speed mode called Power Rec 16x and I left it at that setting. After some time thinking about it, the backup has started running even slower than before at 0.3x. Aaargh!!

760a should be in udma4,if not check cable! and try removing other drive to exclude conflicts.

@haggis999

Hi,

it’s possible that your cd-rom block the IDE bus. Please try your PX-760 as an Single drive at your IDE controller.
Which chipset is used on your motherboard? Sometimes it’s useful to use vendor specific drivers for IDE controllers.

Spooky

Also Dell & HP tend to set their devices as Cable Select , rather than Master/Slave, whereas new drives tend to come as master or slave jumpered.
Incorrect jumper settings could really screw you.

Thanks for all the advice. I will open up the covers and investigate further when my current backup ends in about 1hr 45mins! I’ve already made enough coasters out of perfectly good blank DVD-Rs so I’m going to let it run.

OK, guys, we’re making progress.

I opened up my Dell 670 and checked the cabling and jumpering situation for the two optical drives. My eyes are not good enough to start counting the conductors in a ribbon cable, but it’s the same width as the plugs at each end so I’m guessing that it is probably the right cable (if that’s an invalid guess, then please tell me what to check for). Both drives were jumpered for cable select. I then unearthed a Plextor installation diagram. It appears to be a generic diagram and I can’t be certain it came with the PX-760A rather than an older Plextor drive. This diagram seems to suggest that the Plextor drive should be mounted at the end of the Secondary IDE cable, and jumpered as the Master device. There are no written instructions, only circled items on the diagram.

With similar advice already given in this thread, I went ahead and reinstalled the two drives in this manner and now a test write with my 4x media runs at about 4.1x and another of my backups on 16x media ran at varying speeds of up to at least 8x. I think the backup ran in about 15mins instead of over 3 hours. Verification took an extra 20mins. I don’t know if this is the best I can get, but it is certainly perfectly acceptable. Thanks to all of you for pointing me in the right general direction.

However, the drive is still operating in UDMA2 mode, not UDMA4. Spooky77, you asked me about chipsets. What chipsets are you talking about? How do I check?

@haggis999

I’m talking about the motherboard chipset like:

Intel
nVidia
SiS
VIA
Ali
Uli

I think, that you have a 80pin IDE cable, because I have’nt seen a 40pin cable with “Cable Select” support. Both type’s of cables have a 40pin connector, only the the ribbon is (should) 80pin !

15 minutes sounds good. Do you have tested with only PX-760A connected to your IDE controller, if then UDMA4 is enabled?

Spooky

Just to be precise it’s 80[B]wire[/B] cable.

Visually the individual wires look quite thin on the ribbon.

It could be a setting in the BIOS that’s restricting the DMA mode or it could well be that it’s actually a 40 wire cable.

The suggestion about disconnecting the other drive makes sense and is well worth a try.

@TimC,

yes, you’re right, 80wire cable is better and correct.

Spooky

I’m still confused about the cable situation. You seem to be suggesting that there are both 40-wire and 80-wire ribbon cables, but both have the same 40-pin connectors. How does a 40-pin connector handle 80 wires?

Just out of interest, can anyone explain why Dell and HP would use Cable Select jumpering if it is incompatible with some optical devices (as it appears to be in my case)?

When I can afford the time for another session under the covers, I’ll try disconnecting my CD-ROM drive to see if this persuades the Secondary IDE Channel to operate in UDMA4 mode with the DVD-RW drive.

Spooky77: My Dell 670 has dual Intel 2.8GHz Xeon processors and a nVidia Quadro FX 130 graphics card. Sorry, but I’ve no idea what you mean by “SiS, Ali & Uli”.

The 80wire cables have 2 wires per pin with the additional 1 being Earth I think.

Suppliers who use Cable Select know that with the equipment they supply it will work fine.

Personally all my devices are on CS - that’s 6 HDD & 6 opticals in 2 different PCs - without any having an issue.

Yup - 80-core cables are just 40-core cables with a ground wire inbetween all the wires. It’s supposed to shield the neighbouring wires from interference, and is why you shouldn’t use crappy rounded cables unless they are made with the cores shielded properly (Which almost NONE of them do… and so they end up being WORSE than 40-core cables, but run at ATA66+ speeds -> Data Corruption hell!)